Question Seagate Firecuda 2TB-SSHD unable to Mount(linux)/Initialize(Windows)

LeanMan82

Distinguished
Dec 20, 2011
57
0
18,540
2
TL;DR
HDD
: Seagate FireCuda 2TB Solid State Hybrid Drive Performance SSHD – 3.5 Inch SATA 6Gb/s Flash Accelerated for Gaming PC Desktop (ST2000DX002)
HD Sentinel: Performance=100/100, Health=88/100, Overall Condition=Excellent; S.M.A.R.T shows two areas with "!" icons: "Current Pending Sector Count" and "Off-line Uncorrectable Sector Count" with values of 8.

It was working on Windows before, prior to the restart and then it went caput after the restart. How can I get access to the file system from Windows? If not Windows, on Linux, its not surfacing a /dev/sd* block for me to mount so I'm scratching my head of what to do next. How can I recover the data if I can't access the file system through an OS?

In Depth:
I have the Firecuda 2TB Hybrid Drive and I use it as a supplement storage volume that houses my backups and anything large that needs additional storage. I can probably lose the backups and start those from scratch but the other stuff in there I can't lose, so I am in the usual crisis that comes with storage failures (i.e., lost time, effort, work etc., that I can't afford right now). The problem occurred after I restarted my machine (which has been running for 24/7 nonstop due to work related reasons) and the restart was due to Microsoft Updates. I didn't expect my hard drive to go caput and was hoping everything would be fine after the updates...

After restarting, I noticed my drive was not showing up in File Explorer and upon opening Disk Management, a popup window asks if I would like to initialize the device, otherwise the drive shows up as uninitialized. I promptly ignore this as this would put me on the path of formatting my drive. HD Sentinel shows the SSHD in "Excellent" Performance (100/100) and Health (88/100) so I did not think twice that it was on the verge of corruption. However, S.M.A.R.T shows the "Current Pending Sector Count" and "Off-line Uncorrectable Sector Count" attributes with a value of 8 and exclamation marks and a graph indicating it started on 2021-06-19. If I had known that this could be a possible indication I would have looked closer at the codes rather than using the overall health feature to determine SSHD health.

Since this is just a data drive and there is no Windows OS, I don't see why I am having any issue at all. As a block volume, I should be able to recover the data some way. The "Uninitialized" state of the volume indicates that the MBR was corrupted in some manner that I am unaware of, is there a way for me to recover the MBR? Could this help me get Windows to recognize the SSHD again? If not, how can I access the file system that was on the volume?

Linux is not surfacing a /dev/sd* block for me to mount so I'm scratching my head of what to do. I connect the SSHD via a USB to SATA cable and connect it to my Linux machine. These are the results:
Code:
$ lsusb
Bus 003 Device 004: ID 152d:2338 JMicron Technology Corp. / JMicron USA Technology Corp. JM20337 Hi-Speed USB to SATA & PATA Combo Bridge
$ lshw | grep "JMicron"i
... # removed for sake of brevity
*-usbhost:0                                                                        
     product: xHCI Host Controller                                                 
     vendor: Linux 5.3.0-64-generic xhci-hcd                                       
     physical id: 0                                                                
     bus info: usb@3                                                               
     logical name: usb3                                                            
     version: 5.03                                                                 
     capabilities: usb-2.00                                                        
     configuration: driver=hub slots=15 speed=480Mbit/s                            
   *-usb                                                                           
        description: Mass storage device                                           
        product: USB to ATA/ATAPI bridge                                           
        vendor: JMicron                                                            
        physical id: b                                                             
        bus info: usb@3:b                                                          
        version: 1.00                                                              
        serial: 000000000000                                                       
        capabilities: usb-2.00 scsi                                                
        configuration: driver=usb-storage maxpower=2mA speed=480Mbit/s             
$ lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 465.8G  0 disk
└─sda1   8:1    0 465.8G  0 part /
Essentially, the above shows that the USB cable registers with the system but the SSHD doesn't present a volume as seen by lsblk (2 Terabyte volume not present). So I don't know how to mount the system with what is available to me. How can I recover the data if I can't access the file system through an OS?
 
Last edited:

popatim

Titan
Moderator
Have you tried running any bootable recovery utilities? You may just need to recover the partition instead of all that data.
Also keep in mind you'll need a place to recover the data to. You don't recover the data to the same drive you are recovering it from.

Was this drive always in a USB adapter or did you do that for recovery?
I ask because many USB adapters do not translate drives with true 4k sectors (vs the old standard of 512 bytes) properly.
 

LeanMan82

Distinguished
Dec 20, 2011
57
0
18,540
2
What "bootable revcovery utilities" are you referring to? Can you provide an example?

The drive is an internal drive that worked fine for the last 4 years until the recent boot of my machine. I only took it out of the case when I started to investigate the problem Its connected on a 6 GB/S SATA connector normally. The USB adapter has a separate power adapter and a SATA to USB connector.. I bought a 4 TB HDD a few months ago (actually because I was fearing data corruption but later felt it was unfounded when looking at HD Sentinel) so I do have something to recover data to. I really don't think anything is wrong with the 2TB SSHD in question but I've been reading that this could be a hardware issue. Anyways, any way I can diagnose if this is a hardware or software issue?
 

ASK THE COMMUNITY