Question Seagate Firecuda SSHD is missing ?

Sep 23, 2021
Hey everyone, i got into a little problem and need a solution and/or advice.

So yesterday i was working fine with my ASUS TUF FX504GE which has Seagate Firecuda SSHD inside. A lunch break later, windows is updating (and how shock i am he dare to update my bios from 320 to 323). And my D: drive is gone (which is the firecuda).

I already try checking in device manager, disk mananger, even in the bios and its not there.

Also tried to uninstall and disable windows update (i believe it was the september patch, i even uninstall the august patch KB5005033 too), roll back the bios to 320 and no results

Today i tried the SATA to USB dock in my office, and came back with no results (at one moment there is the 'disk not initialize' thing and it never pop up back)

The SATA to USB dock are fine w/other drive, already try on diffrent OS (linux on VM), also tried from macbook pro

Is the drive just suddenly fail and i should let it go? Or it is a bios & disk firmware thing that windows <swear word deleted> up on my laptop?
Last edited by a moderator: