Seagate hard drive 1 TB not being recognised suddenly


Jun 24, 2012
Hi all !!

Some info:
Seagate freeagent goflex usb 2.0, 1TB
A little over 1 year old.

The drive is suddenly not being recognized on any computer. When I plug it in on any windows computer (I have tried windows 7 and windows XP) I get a message that "USB device not recognized: One of the devices attached to this computer has malfunctioned and windows does not recognize it......".

I have already tried:

1. Trying on 5 different PCs. 3 with windows 7, one with ubuntu linux, and one with XP. Trying on different USB ports on each PC.
2. Opening the device manager, but it only says "unknown device", so I cant do anything. (I read somewhere that I should try to update/uninstall driver, but I can't do any of that I guess) (the same thing happens on any PC)
3. Tried the software diskdigger, but that also doesn't recognize it (doesnt show that the drive is there)

Windows knows that I have connected something, but then cant opAen it. I was working fine till last night.
I have very important data in it. Is there some way to atleast recover that ??

Any help is greatly appreciated. Thank you very much in advance !!
if the usb cable looks fine. it could be the usb board inside the drive or the drive itself. if you need the data you can open the drive unit and try plugging the drive into your may be able to get the drive to work...but you void the warranty if it still has one. if windows and disk tools cant see the bare drive you may need a data recovery lab.