Question Seagate srd00f2 "Desktop Expansion" External Drive, No Power

lahatte

Prominent
Dec 2, 2019
9
0
510
0
Hi,

I have a Seagate SRD00F2 Expansion 4TB drive. It has the e3215-1215a_4d circuit board.

I noticed that the 12V power supply started making a whining noise at some point, so I replaced it with another supply that I had here, but I had to change the plug since the plug on the other supply would not fit. Unfortunately I wasn't thinking and happened to get the polarity reversed. The center lug should have been positive but I connected it as negative. So I suppose that damaged the enclosure board.

I plugged it in and I think the drive worked, but I can't be sure as I was just focused on the new supply not making noise. It was connected to a WD Live media device so I didn't try using it for quite a while.

Anyway, the issue is I find that now the drive will not power on. And the LED on the board does not light.

As I understand it these drives have encryption built onto the board. And I cannot read the drive after removing it from the enclosure and trying it directly attached to my PC (it does spin).

So two things....does anyone know of schematics for this board? OR, if I get a replacement board would it be able to read (decrypt) the drive data? I have seen a E3338-1338A_4D board on ebay, and I don't know it that one would work the same. It looks the same, but.....

Thanks!
 
Last edited:

lahatte

Prominent
Dec 2, 2019
9
0
510
0
Thanks for that. I'll give it a try in a computer. When I plug it in via USB to my Laptop is says it needs formatting.
 

ASK THE COMMUNITY

TRENDING THREADS