Question Secondary HDD disconnects while gaming

Algalorrd

Prominent
May 30, 2019
60
3
545
1
I'm having the following issue:

While playing Call of Duty Moden Warfare, my secondary HDD on which the game is installed disconnects and reconnects. I get a notification stating that a new device has been connected to the computer (my hdd).
The game crashes and battle.net won't locate the game by itself. It makes me locate the game manually.
The hdd I was using was a few years old so I decided to buy a brand new one but the problem persists.
Sometimes the notification that pops up are about the Reserved by the System unit

I've updated the BIOS to the 3003 version but my pc started to crash and to show BSOD so I had to go back to the 2605 version which apparently is the most stable one. Haven't had a single crash with this BIOS version

I have also tried this solution but it didn't work: https://support.microsoft.com/en-us/help/3083627/internal-sata-drives-show-up-as-removeable-media

I've checked the SATA cables and they aren't loose.
I also don't believe it is a problem with the PSU.

Right now I don't know what to do :confused_old:
The only way I've managed to play without these crashes was to transfer the game to the SSD which costed me a lot in terms of storage.

These are my specs:
  • Asus ROG Strix B450F Gaming
  • Ryzen 7 2700x (I've set all cores to 4.1 Ghz perfectly stable - 240mm Deepcool AIO)
  • 2x8 G.Skill Trident Z 3000mhz
  • MSi ARMOR RTX 2070 8G
  • Thermaltake Smart 700W
  • 1 tb Western Digital HDD (the one which is giving me this headache)
  • 500 gb m.2 nvme XPG Spectrix S40G
  • 250 gb Sandisk SSD
All drivers are up to date.
 
Last edited:

Algalorrd

Prominent
May 30, 2019
60
3
545
1
Have you tried new Sata cable and using a different power connector?
Thanks for your reply.

Yes, I've tried both options. None of them solved the issue.

I just noticed something quite weird. Sometimes the pop up message stating that the hd is ready for use is about Disk D and that disk is reserved by the system.
That would be perfectly normal but Windows is installed in the 120 gb ssd and the "Reserved By System" partition is currently on the hdd.
This may sound dumb but: Is this normal?
 

Algalorrd

Prominent
May 30, 2019
60
3
545
1
Use disk management and remove the drive letter for the reserved partition please. Rt click it and select Change Drive letters and paths.
I did that but no deal.
My HDD keeps behaving like a removable device =\ which disconnects randomly. This is driving me mad. I can't find a solution anywhere.
 
Last edited:

popatim

Titan
Moderator
Have you tried setting it as non-removable storage?

You may just need to set the sata port as no hot-swappable in the bios. If not then check the drives policies in device manager.

On the polices tab: Write cache should be on, Optimize for quick removale should be off; on the general tab, make note of the bus number, you might need it later. If you made changes, reboot and check.

If none were needed or the changes did not work then open regedit, backup your current registry, and then add “HKLM\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device” /f /v TreatAsInternalPort /t REG_MULTI_SZ /d x
Where x corresponds to the Bus Number you noted .

Reboot and check again.
 

Algalorrd

Prominent
May 30, 2019
60
3
545
1
Have you tried setting it as non-removable storage?

You may just need to set the sata port as no hot-swappable in the bios. If not then check the drives policies in device manager.

On the polices tab: Write cache should be on, Optimize for quick removale should be off; on the general tab, make note of the bus number, you might need it later. If you made changes, reboot and check.

If none were needed or the changes did not work then open regedit, backup your current registry, and then add “HKLM\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device” /f /v TreatAsInternalPort /t REG_MULTI_SZ /d x
Where x corresponds to the Bus Number you noted .

Reboot and check again.

Thanks again. I'll check that out!
But I already have one doubt: The hdd (which is giving me all this headache) and the m.2 nvme ssd both have the same bus number "0" while the sata ssd has the bus number of "4". Will that be a problem?
 

Algalorrd

Prominent
May 30, 2019
60
3
545
1
How was the hot-swap bios setting and the Policies tab set?
I'm sorry it took a while for me to answer your question.
It's all disabled and I'm still facing this issue. HDD randomly disconnects and reconnects. It behaves like a removable device.

The hot-swap bios is set as disabled. I don't know what else I could do to fix this.
 

Algalorrd

Prominent
May 30, 2019
60
3
545
1
It's been definitely a while since I've posted on this thread.
It turn's out that the solution was quite simple: I went to the control panel's power settings + change plan settings + advanced power settings and set the "turn off hard disk" to "never" and that's it. My problem is solved.

Thanks again to all who replied.
I'll try to be more active on this forum.
 

ASK THE COMMUNITY