Secondary SATA Drive no longer detected


Mar 25, 2009
I have a Dell Dimension 5150. It's been running with 2 SATA HDD's with a dual boot system for 5 years without issue.

Both HDD's are the same

WD Caviar Blue / SE16 320GB 16MB Cache WD3200KS

The Primary Drive has 2 Partitions
1) C: Win XP (Primary Boot)
2) D: Applications (storage)

Secondary HDD has 2 Partitions

1) X: Win 7 Boot
2) Y: Storage

About 3 weeks ago I started getting odd problems with the secondary HDD.

My PC was randomly freezing up or slowing down when attempting to access this drive in XP. Eventually it just stopped being recognized in XP altogether.

Next, my PC wouldn't even boot. I'd receive the message "No boot device available".

After various tinkering, I could get the primary HDD with XP to boot without issues by disabling the secondary SATA port (which 2ns SATA Drive was attached to) in BIOS. When this was turned off the primary HDD booted without issue and I could access XP. Obviously with the secondary SATA port disabled I couldn't reach the secondary HDD to test it.

Again, randomly, I found sometimes when renabling the secondary port in BIOS i could get into XP and see the secondary HDD but eventually it would freeze/crash the system, so I would have to disable it again. Now I'm at a point where I can not enable it at all without the system crashing. Furthest I can get with the secondary port enabled is to the win XP boot logo, then it freezes.

There is obviously ZERO problems with the primary HDD. The problem must lie with either the secondary HDD or the secondary SATA port or ???

When I try to enable the secondary SATA drive in BIOS this is what I receive when saving and rebooting from BIOS

"Error auto-sensing secondary slave hard disk drive

No boot device available

CLIENT MAC ADDR: 00 2B 21 2E 96 67 GUIDE: 44454C4C 3600 1032 8059 B7C04F37324A
PXE-E53: No boot fileame received"

So any ideas appreciated. What I'm doing right after I post this is removing the secondary drive and adding another drive. Then i'll test if the new drive will work in the system and also test the currently non-working drive in another device (external USB).

I need all the data on this secondary drive so if it's buggered i'll be looking for ways to retrieve it if possible.

XP is my primary OS so I'm not worried about losing Win 7

Before it completely stopped allowing me to boot with the secondary device active I tried running chkdsk on the secondary device. This continously failed and stated

"The volume is dirty"
"Corrupt master boot file"

I couldn't get chkdsk to run on it in windows or during boot.

Any ideas or suggestions in the meanwhile appreciated.


Mar 25, 2009
Ok, I removed drive, replaced with a new drive. The new drive is detected and installed and accessible properly.

I tried the dud drive in an external USB caddy and it won't properly detect it. The problem is obviously with the drive so now I need to work out how I can retrieve data from it by any means possible.

The furthest I've got with it is for the drive to be recognized in My Computer but only as a new unformatted disk but then it quickly freezes and doesn't detect it any more.

The disk spins up and down every so often with a single loud click indicating that.

I'me about to try WD diagnostic tools on it.


Feb 2, 2012
Here is my problem in my Dell Dimension 5150

Ram :1024MB on the computer
CPU :Intel Pentium 4

Hard Drives on Sata Hard Drive 0 :

C:Windows XP Home Edition SP3 Boot(60GB)
D:Windows 7 Professional SP1(170GB)

Windows are used :D:Windows 7 Professional SP1(170GB)

Explanation :

Last night on 28 January 2012,this computer was work before.I downloaded DriveImage XML On ''Windows 7 Hard Drive''.After I installed that program,i opened it.After that,I clicked the ''Clone Hard Drive''.After the ''Clone Hard Drive'' was processing,the windows are not responding.I cloned the ''Hard Drive'' 2 times and windows are not responding again.After that,I Shut Down the computer.

Last Morning on 29 January 2012,I power on the computer.After that,The message showed like this :

''No boot device avaible''

Press F1 for retry boot,Press F2 for setup utility

I need your help..........