Question Setting up my home network, problem with DHCP server

A6TH

Honorable
Oct 16, 2013
100
0
10,690
1
I'm trying to set up RP-N12 and RT-N66U so my desktop PC can connect to my home network through Ethernet.
RP-N12 is connected to a wireless repeater (TL-WA850RE), which extends the WiFi signal from my provider's router (ZXHN H267N). RP-N12 is set up in media bridge mode, so it enables a client to connect through its Ethernet port to the WiFi network. I turned off DHCP servers on both TL-WA850RE and RP-N12 since the DHCP server is running on ZXHN H267N.
Here is an illustration of what the network looks like:



The reason I put RT-N66U between RP-N12 and the desktop PC is that the Ethernet cable is not long enough to reach the PC (not possible to upgrade to a longer cable).

However, I'm running into a few problems. My laptop and RP-N12 can successfully obtain their IPs from the DHCP server on ZXHN H267N, but RT-N66U and the desktop PC can't.
Why is that the case? Thank you for your help.
 

kanewolf

Titan
Moderator
I'm trying to set up RP-N12 and RT-N66U so my desktop PC can connect to my home network through Ethernet.
RP-N12 is connected to a wireless repeater (TL-WA850RE), which extends the WiFi signal from my provider's router (ZXHN H267N). RP-N12 is set up in media bridge mode, so it enables a client to connect through its Ethernet port to the WiFi network. I turned off DHCP servers on both TL-WA850RE and RP-N12 since the DHCP server is running on ZXHN H267N.
Here is an illustration of what the network looks like:



The reason I put RT-N66U between RP-N12 and the desktop PC is that the Ethernet cable is not long enough to reach the PC (not possible to upgrade to a longer cable).

However, I'm running into a few problems. My laptop and RP-N12 can successfully obtain their IPs from the DHCP server on ZXHN H267N, but RT-N66U and the desktop PC can't.
Why is that the case? Thank you for your help.
You need to set the N66U in access point mode to disable the DHCP server on it and have your ethernet cables connected to LAN ports.
 

A6TH

Honorable
Oct 16, 2013
100
0
10,690
1
You need to set the N66U in access point mode to disable the DHCP server on it and have your ethernet cables connected to LAN ports.
I set up the RT-N66U in access point mode and connected both the RP-N12 and the desktop PC to its LAN ports, but it still can't obtain the correct IP and takes the IP 192.168.1.1 and default gateway 0.0.0.0.
 
Try hooking the PC directly to the n12. You do not need a longer cable you just need a ethernet coupler to test. I suspect it is the n12

The problem you have with "bridge" mode is that there are many variants and no consistent name. The simple client bridge only supports a single device mostly because the mac address is used in the wifi encryption keys. The next type of client bridge uses WDS. This is how most repeaters wor and solves the problem of mulitple mac. Problem is WDS is not always supported. The third version is becoming more common. This version runs as a router even though they call it "bridge". This solves the single mac and lack of WDS support issues but now you are on a different network. WDS also does not always support repeater to repeater which is the case you have.
 

kanewolf

Titan
Moderator
I set up the RT-N66U in access point mode and connected both the RP-N12 and the desktop PC to its LAN ports, but it still can't obtain the correct IP and takes the IP 192.168.1.1 and default gateway 0.0.0.0.
Verify that your PC has DHCP enabled. An IP address of 192.168.1.1 is not the typical behavior for no DHCP. A 169.x.y.z address is the default no DHCP behavior.
 

ASK THE COMMUNITY

TRENDING THREADS