Sharing Win 7 Pro My Documents folder with Win 10 Pro machine on LAN?

RLANCx

Commendable
Jan 6, 2017
6
0
1,510
0
I need to share the entire My Documents folder structure on a Win 7 Pro machine privately with a Win 10 Pro machine and have found no way to do this. A Homegroup doesn't seem to be the answer because that feature supposedly specifically omits the My Documents folder structure, which is what I need to share. I have found lots of sharing solutions that throw the My Documents folder structure open to the entire network, but I need to restrict access to only one machine on the LAN (no outside Internet access required). Ideally I would like to just be able to log in to a (Win 7) networked drive (My Documents) with the Win 10 machine using the usual saved network login process. Any workable solutions to these requirements would be greatly appreciated.
 

Rhinofart

Distinguished
Jan 30, 2006
977
0
19,360
106
What you have to do is go through the file system, not the quick links in windows explorer. Open file browser, goto C:\users\YOURUSERNAMEHERE\ My Documents Right click on it, and select sharing. Click on Advanced Sharing. Put a checkmark in the Share this folder button. Change the Sharename to something else, and put a $ at the end of it. This will make it a hidden share that won't be browsable by other computers on the network. IE Share name: Win7Docs4Brian$ and then change your permissions as needed. Just remember, if you are sharing this folder with someone else, you will have to enable NTFS permissions as well. Shared folders have 2 sets of permissions. The Share Permissions, and the actual file system Permissions.
 

popatim

Titan
Moderator
I'm not sure if this will do exactly what you want as I've never shared a directory structure before; sorry if it doesn't

open explorer
rt click 'Documents' (top left in the libraries section)
Hold mouse over 'Share With'
click on 'Specific People'

The remote user then can map a drive letter to your documents folder. Please note that the default remote user access is read-only unless you changed it.
 

RLANCx

Commendable
Jan 6, 2017
6
0
1,510
0


 

RLANCx

Commendable
Jan 6, 2017
6
0
1,510
0
Doesn't work as part of the problem with Windows 7 is that when you right click the user's My Documents folder you are not presented with the 'Share With' choice.
 

Rhinofart

Distinguished
Jan 30, 2006
977
0
19,360
106
What you have to do is go through the file system, not the quick links in windows explorer. Open file browser, goto C:\users\YOURUSERNAMEHERE\ My Documents Right click on it, and select sharing. Click on Advanced Sharing. Put a checkmark in the Share this folder button. Change the Sharename to something else, and put a $ at the end of it. This will make it a hidden share that won't be browsable by other computers on the network. IE Share name: Win7Docs4Brian$ and then change your permissions as needed. Just remember, if you are sharing this folder with someone else, you will have to enable NTFS permissions as well. Shared folders have 2 sets of permissions. The Share Permissions, and the actual file system Permissions.
 

Rhinofart

Distinguished
Jan 30, 2006
977
0
19,360
106
Forgot to add in the above post, that on the Win10 machine open up file browser, and in the top address bar type \\WIN7COMPUTERNAME\SHARENAME$ to access the folder. I shouldn't have to tell you, but just incase substitute the win7computername and sharename$ to whatever fits your actual setup.
 

RLANCx

Commendable
Jan 6, 2017
6
0
1,510
0
Thanks Rhinofart, but I actually worked this out this morning and didn't have time to post before you did. I was trying to set this sharing up remotely and initially thought that sharing was being blocked because of my remote connection because I kept getting a dialog about trying to set permissions remotely instead of locally. This obtusely worded dialog, I think, is trying to say what you did, that you have to go to the actual file location (under Users) to set the permissions instead of doing it at the My Documents location at the top of the Windows Explorer tree. After getting the same dialog after going to the computer and attempting the same thing, it finally dawned on me.
 

Rhinofart

Distinguished
Jan 30, 2006
977
0
19,360
106


Beauty! Glad you got it all sorted.

 

ASK THE COMMUNITY

TRENDING THREADS