Question Shell Infrastructure Host (sihhost.exe) using up upto 20-40% CPU while PC is Idle ?

nooblet0

Reputable
Apr 14, 2019
29
1
4,535
0
Title says it all really. This process(which as far as I can tell is genuine) is chugging up a ton of resources while seemingly doing nothing at all. Apparently its related to UI transparency but I don't even use a transparent theme. Any ideas as to how to get rid of this, it seems to impact performance quite a bit.
The issue is completely random and I first noticed it about a month ago. Its fairly infrequent and seems to go away with a restart(not the process itself but the high resource consumption) but I've been noticing it more frequently recently, hence the post.


 
Title says it all really. This process(which as far as I can tell is genuine) is chugging up a ton of resources while seemingly doing nothing at all. Apparently its related to UI transparency but I don't even use a transparent theme. Any ideas as to how to get rid of this, it seems to impact performance quite a bit.
The issue is completely random and I first noticed it about a month ago. Its fairly infrequent and seems to go away with a restart(not the process itself but the high resource consumption) but I've been noticing it more frequently recently, hence the post.


Some reading.

https://www.google.com/search?q=shell+infrastructure+host+high+cpu&hl=en&source=hp&ei=8hmrYviOLYGp5NoPpJKLoAs&iflsig=AJiK0e8AAAAAYqsoAqRi_-UooHbjfV_sp-2lLqsmL79x&oq=Shell+Infrastructure+Host&gs_lcp=Cgdnd3Mtd2l6EAEYATILCAAQgAQQsQMQgwEyBQgAEIAEMgUIABCABDIFCAAQgAQyBQgAEIAEMgUIABCABDIFCAAQgAQyBQgAEIAEMgUIABCABDIFCAAQgARQAFgAYMYxaABwAHgAgAE3iAE3kgEBMZgBAKABAqABAQ&sclient=gws-wiz
 

ASK THE COMMUNITY

TRENDING THREADS