Short, but complete, system freeze on HDD wake-up

Nov 22, 2018
1
0
10
0
Hey guys!

So. I just got a new rig!

The most essential components are as follows:

Intel Core i7-8700K

Corsair Hydro Series, H100i PRO

HyperX Fury DDR4 2666MHz 16GB

ASUS ROG STRIX Z370-H Gaming, S1151

Gigabyte GeForce GTX 1080 Ti Gaming OC

Kingston A1000 480GB M.2 SSD (For windows installation, naturally)

Crucial MX500 1TB 2.5" SSD

In addition to this new hardware, I also popped in my old storage devices from my previous build:

Intel 530 Series 120GB 2.5" SSD (Also has a Windows 10 installation on it, I'll get to that later)

Seagate Barracuda 2TB 3.5"

And finally a really old Hitachi HDD that I (granted, with limited research) only know as:

"Hitachi HDP725050GLA360" 500GB

All running Windows 10 Home.

Now. I have one very annoying issue.

If I keep the default power saving settings in windows 10 that allow hard drives to shut down after 20 minutes of being idle, when they spin up again (randomly for whatever Windows wants with them) the whole system freezes until they're spun up.

I don't have any windows essential software installed on these other, older, drives that are presumably the ones shutting off then waking back up after a while.

Which leaves me to wonder why it's causing a temporary complete system freeze. My mouse cursor is frozen in place, audio sometimes continues playing I think, but all visuals freeze.

Here's the weirdest part:

I mentioned before that the older Intel SSD I have in my system has a Windows 10 installation on it as well. (This was my older windows installation on the previous PC)

When I boot to that windows installation, this issue doesn't seem to occur... The Hitachi drive is probably the only one shutting down and waking up on that windows partition because I have a lot of software installed on the 2TB Seagate drive on that particular windows installation, so it probably never gets to go idle for long enough.

It's really strange, at least the Hitachi drive shuts down and wakes back up and completely without any system freezes.

I'd really like to be able to let the idle storage units shut down, because they're loud and for longevity. But as it is now, I can't risk having a complete system lock up whenever the drive(s) decide to wake up. So I have to disable the power saving setting for it.

I know this is a really long post. I'm sorry. For anyone that wants to help me with this issue, I appreciate it greatly.

Looking forward to any answers and ideas.

-gP
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS