[SOLVED] Should I replace my PSU ?

Feb 5, 2022
40
3
45
1
I've been having this problem over these couple of years, the PC starts ; fans spin, LED lights, HHDs startup but no display at all and no POST beeps.

In the first signs of this problem it was fixable and sometimes the PC boots up and sometimes you had to manually detach the CMOS battery for a few minutes, but that's no longer working and the PC continues to not boot up or make any beeps.

I tested the monitor on other devices such as a laptop and another MSI PC, I also checked the DVI cable and it's working fine with other devices and when I plug it in my PCs GPU the monitor responds and goes black.

I unplugged every component then booted up, starting from the CMOS battery, the GPU, the CPU, the HDD, and the 2 sticks of RAM. But there's no different whatsoever.

The PC is old and has over a decade, so maybe the PSU is gone bad or damaged somehow, the lifespan of the PSU is 5-10 years, and my PC's age this years is 10 years old, so I suspect that the PSU is bad.

I also recently applied a new thermal paste for the CPU, if that's a concern.

The rig is pretty old, I got it in 2011 and that answers the PSU's age, althought, this is my setup :
PSU:
Hipro HP-D3057F3R 300W
CPU:
Intel® Core™2 Quad Processor Q8200
CPU Cooler:
Intel® Stock Cooler (LGA 755)
Motherboard:
ASRock g31m-s
Ram:
2 Sticks of TwinMOS DDR2-667 2GB U-DIMM
SSD/HDD:
Samsung HD502HJ 500GB (using)
Seagate Barracuda 7200.11 500GB (not using)

GPU:
NVIDIA GeForce 9500 GT 1 GB
Chassis:
Unknown ( I couldn't find it anywhere )
OS:
Windows 10 x64 (latest version or below)
Monitor:
Samsung SyncMaster P2350 60Hrz
 
Feb 5, 2022
40
3
45
1
I would play taps, salute it and lay it to rest. It has served you well. You could spend $30 to see if it is your psu, or it could be your motherboard has died. It is your call.
There's a PSU that I found online for a cheap 15$ and it is double the watts my current PSU has, here's the link:
https://www.mytek.tn/bloc-d-alimentation-bloc-600w.html

Also, how could I tell that the motherboard is the problem and not the PSU ?
 
Feb 5, 2022
40
3
45
1
Well, after trying to fix a display problem and failing after trying all the solutions including removing pc parts to fix the problem it got down to the power supply and the motherboard itself.

Stupid me decided to switch the red switch from the default 230V to a 115V, and AS soon as I plugged in the power cable...BOOOM! PSU exploded with a loud bang and a strange looking blue flash.

And when that happened I rushed and unplugged every cable there is, even the inside 8 PIN, CPU and hard drive power cables. I checked for burn marks on all the components ; luckely didn't find any they looked normal and untouched.

Well, I had to get a new PSU anyways to see if it fixes the stupid display problem and now I certainly need it, but before going to get a new one what do you guys think happened ? Did the PSU fry the motherboard ?

Here's the PSU's name :
Hipro HP-D3057F3R 300W
 
Feb 5, 2022
40
3
45
1
The psu potentially could have damaged everything connected to it. Only way to know is test every component.
Well, I don't have a spare PC or a friend that can help, I'm still going to get a new PSU to test it,
Is there any chance of the motherboard surviving ? I heard undervolting doesn't do that much...
 
Feb 5, 2022
40
3
45
1
Well I have to replace the PSU anyways because it exploded...BOOM !
Move to this thread :
 
Well, I don't have a spare PC or a friend that can help, I'm still going to get a new PSU to test it,
Is there any chance of the motherboard surviving ? I heard undervolting doesn't do that much...
What you did was not undervolting. You made the psu expect 115v when plugged into 230v. You put double the voltage into that psu setting.

You might be lucky and only the psu was damaged, but I would not be surprised if there was more damage.
 

Gam3r01

Titan
Moderator
well, if you flip that red switch from 230v to 115v, only thing that happens is that fuse gets blown out, its replaceable
Thats the way it should work, yes.
However, the quality of the unit plays a large role here. A quality PSU with proper, tested safeguards in place? Typically would sacrifice itself to save the rest of the components.
A cheaply made, poor quality unit has less effective or even lacks basic protections, which would still overvolt the entire system.
Sure the fuse blew, but how long did that fuse take to blow? Its very quick regardless but if any of that increased voltage made it though, which it probably did, its a different matter.

Hint, if a PSU has a voltage switch like that, its probably safe to assume it wasnt quality in the first place, and the chances of the rest of the components being unharmed is lower.
 
Well I have to replace the PSU anyways because it exploded...BOOM !
Move to this thread :
The 'best solution' would be Post #5..
 

NightHawkRMX

Polypheme
Ambassador
I've found a lot of Hipro units in older Dell systems, and they probably could found elsewhere too. Should be okay as far as quality is concerned.

Even if the fuse didn't pop the damage should be only to the primary side of the PSU, which means your hardware is likely to be unaffected.

However, you would need another PSU to test your computer with to be sure. You should replace your PSU at this point regardless.

What are the full specs of your system?
 
Over 50 years ago, when devices with that type of voltage switches were common, I did the same to a radio. It was totally destroyed.
Luckily electric devices with voltage switches like that aren't allowed to be sold in the EU since over a decade. I don't know about other regions.
 
Feb 5, 2022
40
3
45
1
I've found a lot of Hipro units in older Dell systems, and they probably could found elsewhere too. Should be okay as far as quality is concerned.

Even if the fuse didn't pop the damage should be only to the primary side of the PSU, which means your hardware is likely to be unaffected.

However, you would need another PSU to test your computer with to be sure. You should replace your PSU at this point regardless.

What are the full specs of your system?
Yeah the PC I'm using is a gaming PC from 2011, it has served me well to be honest... I feel kinda bad for doing this even tho I hated the stupid display problem that it has been doing recently.
Hope things get back together when I replace the PSU
 

ASK THE COMMUNITY

TRENDING THREADS