[SOLVED] Showing 15.9gb instead of 32gb

Status
Not open for further replies.
Feb 11, 2021
4
0
10
I recently installed new WD black ssd. Everything was running fine but after this my windows are showing 15.9gb ram
My system is AMD ryzen 2700
Asus rox x470
G.skill Trident 8gbx 4
I tried reinstalling windows

Bios is showing 32gb
I tried CPU Z and it is showing 32gb but dxdiag and windows is showing 15.9gb. I tried removing and rearranging memory sticks. Please help if someone has solution.
 
Solution
I enabled fast boot and cant access bios :/

go to settings/update & security/recovery
under advanced startup, click restart now button
this restarts PC in a blue menu
choose troubleshoot
choose advanced
choose UEFI Firmware interface
this should restart PC and put you in bios.

Does it show as 15.9 regardless of which stick you use?
does ram go up if you take nvme out?
I don't get what connection could be.

what are rest of specs of the PC?

Colif

Win 11 Master
Moderator
Try running memtest86 on each of your ram sticks, one stick at a time, up to 4 passes. Only error count you want is 0, any higher could be cause of the BSOD. Remove/replace ram sticks with errors. Memtest is created as a bootable USB so that you don’t need windows to run it

strange ram amount goes down after installing nvme.
 
  • Like
Reactions: Gladiatorbtk1
Feb 11, 2021
4
0
10
Try running memtest86 on each of your ram sticks, one stick at a time, up to 4 passes. Only error count you want is 0, any higher could be cause of the BSOD. Remove/replace ram sticks with errors. Memtest is created as a bootable USB so that you don’t need windows to run it

strange ram amount goes down after installing nvme.
Thanks bro. I ran test everything was ok. After that I updated bios and windows. Now it is showing 32gb (15.9 usable) tried disabling paging and all other methods (msconfig). All in vain. Now i have another issue. I enabled fast boot and cant access bios :/
 

Colif

Win 11 Master
Moderator
I enabled fast boot and cant access bios :/

go to settings/update & security/recovery
under advanced startup, click restart now button
this restarts PC in a blue menu
choose troubleshoot
choose advanced
choose UEFI Firmware interface
this should restart PC and put you in bios.

Does it show as 15.9 regardless of which stick you use?
does ram go up if you take nvme out?
I don't get what connection could be.

what are rest of specs of the PC?
 
Solution
Feb 11, 2021
4
0
10
go to settings/update & security/recovery
under advanced startup, click restart now button
this restarts PC in a blue menu
choose troubleshoot
choose advanced
choose UEFI Firmware interface
this should restart PC and put you in bios.

Does it show as 15.9 regardless of which stick you use?
does ram go up if you take nvme out?
I don't get what connection could be.

what are rest of specs of the PC?
I tried using 1 memory stick at a time. All were functioning properly showing 8GB. I think it is connected with ssd. I can't test only with HDD because i removed OS from it and cant reinstall as it is not MBR.
 
Status
Not open for further replies.

TRENDING THREADS