Question Shuddering/micro Freezing at 144hz but NOT at 60hz

Snezzey

Reputable
May 27, 2016
6
0
4,510
0
I have just picked up a complete new system (Details below) Having installed a couple of games (WoW and R6 Siege as examples) I have run into an issue.

I Play on a MSI Optix G27C2 144hz Monitor. For this My obvious first step was to set the adapter to utilize the 144hz as well as set this in-game. Upon doing so Every game I tried became a stuttery, unsmooth mess. However when changing both the adapter and game back to 60hz it seems to run smoothly (or at least a million times smoother then it was at 144hz) and no I don't have vsync on usually however I had no change with it on.

I have tried reinstalling both the current and older video drivers and made sure my system was up to date.

Any ideas?

(System -
  • Intel Core i9 9900K Processor
  • ASUS ROG Maximus XI Code Motherboard
  • be quiet! Dark Power Pro 11 1200W Power Supply
  • Corsair Vengeance RGB Pro CMW32GX4M4C3200C16 32GB (4x8GB) DDR4
  • MSI GeForce RTX 2080 Ti Gaming X Trio 11GB)
 

Snezzey

Reputable
May 27, 2016
6
0
4,510
0
All that for 1080p? What the fuuuuuuuu....

Have you enabled Gsync in the nvidia menu?

FYI: you could've spent over $1500 less for the same outcome.
LOL literally had the EXACT same comment in a couple places, i KNOW the monitor is old, i'm aiming for a 4k 120hz in the near future. Its just there for the time being as its left over from my last build. I promise.

Ended up shifting it to adaptive sync and has cleared up any trouble. :)
 

ASK THE COMMUNITY

TRENDING THREADS