SideBySide

Gandalf

Distinguished
Dec 12, 2009
1,303
0
19,460
60
I use Windows 7 Ultimate. To my knowledge, I don't use SideBySide. Whatever that is. My Event Viewer reports the following from source "SideBySide":

Event ID 35
Activation context generation failed for "c:\program files (x86)\windows live\photo gallery\MovieMaker.Exe".Error in manifest or policy file "c:\program files (x86)\windows live\photo gallery\WLMFDS.DLL" on line 8. Component identity found in manifest does not match the identity of the component requested. Reference is WLMFDS,processorArchitecture="AMD64",type="win32",version="1.0.0.1". Definition is WLMFDS,processorArchitecture="x86",type="win32",version="1.0.0.1". Please use sxstrace.exe for detailed diagnosis.

Event 59
Activation context generation failed for "c:\program files (x86)\microsoft\search enhancement pack\search helper\sepsearchhelperie.dll".Error in manifest or policy file "c:\program files (x86)\microsoft\search enhancement pack\search helper\sepsearchhelperie.dll" on line 2. Invalid Xml syntax.

I don't use MovieMaker.exe, so why the first event? How do I fix it?

I have no idea about how to fix the second event.

 

Ijack

Splendid
Jul 30, 2008
7,169
0
29,710
700
Trawling the web, SideBySide seems to be something to do with Microsoft Search. The general advice is to install the Visual C++ Redistributable files. Couldn't do any harm to give that a go. (It seems to be looking for 32-bit files, so I'd try the 32-bit version first and then, as you have 64-bit Windows 7, if that fails try the 64-bit version.)
 

Gandalf

Distinguished
Dec 12, 2009
1,303
0
19,460
60


I tried the 32bit version. That didn't work so I tried the 64bit version.
Unfortunitely, that had the same results. Any other ideas?

By the way, these errors seem to occur about 12:30 AM when I'm asleep. For what it's worth, these errors are not occurring on my laptop running Vista. Therefore, these errors seem to be solely a Windows 7 thing.

 

Ijack

Splendid
Jul 30, 2008
7,169
0
29,710
700
On a closer look at your problem, I found this from Microsoft. It appears that the first error it is a known problem and the official solution is "ignore it"! But it does beg the question why it occurs, as you say you don't use MovieMaker. I wonder if Windows Update could be causing it - do you know what time it runs?

I guess if it really bothers you you could uninstall MovieMaker.
 

Gandalf

Distinguished
Dec 12, 2009
1,303
0
19,460
60
Don't you just love that kind of "official solution" from MS?

As for the Windows Update, mine automatically runs at 3AM.

I have a hatred of event errors and correct them whenever I can. Maybe it comes from running a network test lab at one time. I always wonder what Beta testers test for when so many event errors can occur that MS supposedly has no knowledge of.

Thanks ijack for trying.
 

Gandalf

Distinguished
Dec 12, 2009
1,303
0
19,460
60
I appear to have resolved the errors by removing the offending folders.
I don't like having to resort to that kind of drastic step, but if Microsoft won't fix the problem, I see no other course.
I don't see this as a solution, only a workaround.

If the MS solution is to ignore the error, why did they make it an error to begin with?
That is a retorical question. I don't expect an answer.
 

Montreal

Distinguished
Jan 19, 2010
1
0
18,510
0


FYI this also happens with other applications such as Adobe Acrobat and AIR. Removing those apps is not an option but it certainly is bothersome to see them in the event viewer so frequently. Have 5 machines doing this allW7 Ultimate 64 bit
 

shawn_holloway

Distinguished
Mar 26, 2010
4
0
18,510
0
I do experience this same problem. I'm on windows 7 ultimate 32-bit. I just recently realize i have this problem. I installed nero 9 and side by side came out. Awhile later i couldn't even open a picture (all file type) but if i right clicked the pic and press preview amazingly it works!. But for my nero i can't do anything. :(
 

kryfreeman

Distinguished
Jun 7, 2009
1
0
18,510
0
I had the same problem and found the answer here:
http://social.technet.microsoft.com/Forums/en/itprovistaapps/thread/a4c36078-6419-4424-8a43-ff3832786b59
I downloaded the trial of Resource Tuner from http://www.restuner.com/ (because I didn't have Visual Basic), saved a copy of Moviemaker.exe as Moviemaker.old.exe, then opened the original Moviemaker.exe file in it, used the editor to remove

<dependency><dependentAssembly><assemblyIdentity type="win32" name="WLMFDS" version="1.0.0.1" processorArchitecture="*"></assemblyIdentity></dependentAssembly></dependency>

from the manifest, saved it, and no more event errors. I'm assuming the "*" wildcard is what's causing the error.
 
G

Guest

Guest


i get the same error at 12:30 ish and usually my computer restarts. jim a.
 

pbparker

Distinguished
Aug 21, 2010
1
0
18,510
0
Microsoft Update causes this error to show up in the Event Log periodically, when it checks against known installed components and their dependencies...

Probably not desirable to delete the reference entirely...

Better is to change from processorArchitecture="*" to processorArchitecture="x86", which is the correct reference for the
WLMFDS dependency.

Coding error on the part of original Microsoft programmer in creating the manifest.

Once patched, MovieMaker will correctly reference the dependent DLL and no errors will be reported...