Question Signal Cable Not Connected! - HDMi - It worked before, and works with other laptops.

Nov 16, 2020
3
0
10
0
Hey guys,

I use a laptop (MSI GL63 8SD) connected to a monitor (iiyama ProLite XB2483HSU) with HDMi as an extended display. It worked normally until I decided to physically turn the monitor by 180 degrees towards the sofa as I wanted to watch a movie from comfort.

After I've done that I realised that the screen was sligthly flickering, so I unplugged the HDMi from the monitor and plugged it back right again. I get the message "Signal Cable Not Connected!" since then.

What really bugs me is that my work-laptop and also my girlfriend's laptop works fine with the same cable and the monitor, and my MSI seems to be recognising the secondary display as well, yet there is no signal.

I tried to solve the problem by:
- powering off everything and replugging cables several times
- made sure it was in extended mode (Win+P)
- made sure that the monitor is in HDMi mode
- updated Nvidia driver

I don't know where the problem is. Maybe some kind of driver got messy?

Thanks for your help in advance!
 

Ralston18

Titan
Moderator
"MSI seems to be recognising the secondary display as well, yet there is no signal." How was " recognising " determined?

Take a close look at your MSI laptop's HDMI port. Use a bright flashlight and a magnifying glass if necessary.

Look for signs of damage or misalignment around the laptop's HDMI port. May be debris of some sort interring with connectivity.

Plug in the HDMI cable and try again but gently wiggle and twist HDMI plug to determine if some movement or pressure restores the signal.
 
Reactions: Selopalago
Nov 16, 2020
3
0
10
0
Recognising I mean, the display settings pop up in nvidia control panel, I can even set the audio to the monitor speakers (not working of course), I can even draw the mouse out of the screen like it was extended, yet no signal... it is weird....

I triple checked the HDMi port on the MSI but I didn't find any damage on it. Also tried the wiggling thing on both ends, I was hoping it would work but it didn't.
 

ASK THE COMMUNITY

TRENDING THREADS