Skype opens itself

unplanned bacon

Honorable
Jan 11, 2014
1,598
0
11,810
17


It's not set to run at boot AFAIK. I can be playing a game or streaming a video and half an hour in (or several hours after my PC was turned on) Skype opens
 

Lewiswatson55

Reputable
Sep 17, 2014
16
0
4,510
0
This is a setting within the program itself really easy to disable, I disabled it too as it got annoying.

Here's how to fix it(Assuming you are using windows);
1. Open Skype
2. Navigate to tools tab at the top of the program (or use ctrl+,).
3. You should see a screen pop up, make sure at the side of the new window 'General Settings is in blue'
4. On the right-hand side there is a number of settings with boxes at the start, find the third one down that says "Start skype when I start windows"
5. Uncheck the box then press save at the bottom right side.
6. That's you done.

Now the next time you turn your computer on it shouldn't open :)
Hope this helped :)

Lewis W
 

liydah

Reputable
Aug 6, 2015
10
0
4,510
0
Bumping this as I get the same problem.

To reiterate, the problem is not that Skype starts on windows start up, but rather seems to open itself at random times during PC use.

Windows 10
Skype version 7.25.0.103

Thanks in advance

 

VincentP

Distinguished
Skype may try to take focus if a message comes in, but it needs to be running first.
If you disable startup with Windows and exit skype when not in use, it shouldn't happen.
Note that to exit skype you need to right click on the taskbar icon and exit, not just close the skype window.
 

unplanned bacon

Honorable
Jan 11, 2014
1,598
0
11,810
17


1) It wasn't even running
2) It wasn't set to run at startup. If it was it would have opened the second Windows started.

This lead to

3) I uninstalled it. I never used it. I only became aware of it again when it decided to open whenever it wanted, whether I\m playing a game or not (sometimes hours after my computer has logged in)
 

DLE

Reputable
Jul 22, 2014
17
0
4,510
0


 

DLE

Reputable
Jul 22, 2014
17
0
4,510
0
I don't have an answer but I have the same problem in Windows 8.1 and my computer is generally on 24/7 so no "on boot" is involved. It just started within the last 24-hours. The only way to stop Skyp from restarting immediately is the end the task in Task Manager, however after a while Skyp will start itself again.

No doubt this is Microsoft being "user friendly" but I'm a user and I do not consider this as friendly!

Question to Iiydah: Did uninstalling actually stop this zombie behavior?
 

Colif

Titan
Moderator
NOt sure if this will help

Go to settings/privacy/background apps
If Skype appears in the list disable it from running and it shouldn't just start itself randomly
You may need to turn off messaging instead.
I don't have it installed so all that appears for me is Skype preview.
 

DLE

Reputable
Jul 22, 2014
17
0
4,510
0


 

DLE

Reputable
Jul 22, 2014
17
0
4,510
0
Go to settings/privacy/background apps - Problem: There is no "background apps" in "settings/privacy".

Is that the path in Windows 10? As I said, I am using Windows 8.1 (Tried Windows 10 and realized it wasn't ready for prime time.)
 

Guy_6_

Commendable
Aug 30, 2016
3
0
1,510
0
Today was the first time this happened to new too.
I'm also on windows 10.
I was talking on Skype on my phone (which is SUPPOSED to be on anyways) and I wasn't in front of my computer, later, when I got a message on Skype I walked in front of my computer and Skype opened itself automatically.
I don't rule out having a ghost at home (we have stranger occurrences here), but I actually think windows (like my phone)is studying my behavioral patterns and trying to adapt to my preferences...sometimes it's helpful (like having windows learn my headphone volume preferences,etc) sometimes it's creepy and reminds me of that Adam Sandler movie "click"...
Anyhow, I disregarded it and turned it off manually. I hope it won't recur.
 

Colif

Titan
Moderator
Do you have a camera on PC? As only other way PC would know you nearby is GPS in mobile. I have dumb PC, it has no camera, no microphone, no way to know of knowing if I am here unless I type or it checks my phone GPS location, and that isn't a 100% bet I have phone with me.. though its close.
 

Guy_6_

Commendable
Aug 30, 2016
3
0
1,510
0


 

Guy_6_

Commendable
Aug 30, 2016
3
0
1,510
0
It's a laptop with a built in cam. And my phone and laptop have been connected in the past. But they are not synced as far as I know.
 

GORT-88

Commendable
Aug 31, 2016
1
0
1,510
0


This issue has nothing to do with which version of Windows you're running. Go to Component Services (or whatever your version of Windows calls Services), and look for the Skype Updater. You'll notice that this service is set to run automatically, and is, of course, independent of any Startup settings. My guess is that whenever Skype gets automatically updated, or possibly just whenever it checks for updates, it fires up Skype. This is a bug, and needs to be corrected asap. All too often quasi-professional programmers make changes and then fail to test them properly. The lack of real QC is one of the biggest problems in the industry, and yet it's an easy fix - just test your code! For decades the inside joke among Systems Programmers has been "We don't need to test our code - users will do it for us."

[==*==]
 

Colif

Titan
Moderator
If that were the cause, wouldn't it do it to everyone? I have Skype installed and the updater in services is set to auto but its currently stopped on my PC. Never had it open up on this user. Maybe you need to use it for it to behave like this.
 

Sensestudiosdotus

Commendable
Sep 2, 2016
1
0
1,510
0
I believe it has to do with their automatic update feature.

In the Skype tools menu choose [options].
Within options chooses [advanced settings].
In the left column below advanced settings choose [automatic updates].
Click the button to turn off automatic updates.

I think this will solve the problem. I agree it made me very uncomfortable when Skype started itself after 5 hours on my computer. Best of luck.

Ben
 

DerekZoolander

Commendable
Sep 23, 2016
1
0
1,510
0
This has been driving me nuts. After hours on the web, I think I found a solution. Go to Programs and Features in Control Panel and right click on Avast. Click Uninstall. A window pops with the choices: Update, Repair, Modify, Uninstall. Click Modify. Uncheck Software Updater.
Seems to have done the trick.
 

irthinker

Honorable
Aug 15, 2012
15
0
10,510
0
I also have every auto start turned off. Like another user suggested, I am guessing that it starts itself when it autoupdates. I am turning that off and hoping. I do NOT like apps turning themselves on unless I tell them to...
 

ASK THE COMMUNITY