Skyrim bad performance 5870matrix 2gig

domfather

Distinguished
Dec 6, 2011
40
0
18,530
0
Just need some advise skyrim detects my video settings and sets it to high.i would of thought my system could run this on close to ultra (aa) yet if i run the game on the detected settings the fps is BAD .i can only seemto run games without AA. I have had a feeling for a bit now that some hardware may not be setup on my pc correctly. Can somone verify if this is normal performance with my system?thanks
running it @1920x1080

spec
windows 7 64bit
asus crosshair IV formula
amd phenom 1090T x6 black edition 3.72ghz(not overclocked)
4 gigs kingston hyper x 2000mhz
corsair HX 1000watt
asus 5870 matrix 2gig(not overclocked)
WD caviar black 1T sata3

anymore info needed just ask..thanks
 

Eldd

Distinguished
Sep 6, 2008
710
0
19,060
30
I don't think there's a good set of drivers for ATi's Crossfire for Skyrim, so try to disable that and use only one 5870, it'll get you more FPS.

Second, the game will use only two cores out of your Phenom 1090; then, unless you apply some hack that's been mentioned on these forums (please search for that yourself) the game will only use 2GB RAM.

But mainly in this case the problem lies with your running the 5870 Crossfire. I am getting 70+ FPS with a single 5770, so you should be around there yourself, if not higher, on a single GPU.
 

domfather

Distinguished
Dec 6, 2011
40
0
18,530
0





what driver and settings do u have for ccc?
 

Eldd

Distinguished
Sep 6, 2008
710
0
19,060
30
Oh sorry, mate, I saw 2Gig at the end of your listed card and mistook it for x2.

Ok, I am not running any AA or AF, they're off. I've got all reflections on, all detail set to High, the view distance is maxxed out on everything, distant object detail is set to medium. And indeed, my gaming resolution is same as yours, 1920x1080. There's an FPS unlocker on Skyrim Nexus which might help you. At least for me, I went up from being capped to 60 FPS, to more than 70 in most areas.
 

Eldd

Distinguished
Sep 6, 2008
710
0
19,060
30
Driver's Catalyst 11.9.

CCC settings:

Smoothvision HD: AA - use application settings; Filter: Box
Smoothvision HD: AF - use application settings
Tessellation: use application settings
Catalyst AI: texture filtering set to Quality, Enable surface format optimization is checked
Mipmap detail level: set to High quality
Wait for vertical refresh: off unless application specifies
OpenGL: triple buffering unchecked.
 

domfather

Distinguished
Dec 6, 2011
40
0
18,530
0
damm so dose that meen my system is not powerfull enoght to run this game on ultra settings then? or is this just bad optimization from the game itself? thanks eldd i will try these fps limiter thing. antizig not sure what u meen by disableing all post processing.is that to do with the ini file? im new with tweeking files
 

domfather

Distinguished
Dec 6, 2011
40
0
18,530
0


i want to max the game with the settings i posted not lower the quality. if it meens having to upgrade then what part of my system is lacking in order to do this?
 
we are trying to figure out what is giving you low fps. theoretically your hardware should be ample for at least medium settings with no problems.

if you don't care about that, then for maxing you can find one of the multitude of bench marks for the game and see what was the top hardware they used to max the game.
 

ASK THE COMMUNITY