[SOLVED] Skyrim gaming problem with SSDs

sinshock555

Prominent
Feb 23, 2019
6
0
510
0
So I have a 3 year-old desktop system (Specs below), and was playing modded Skyrim on my SSD (Western Digital Green) smoothly and stable until my SSD died and I have to change SSD, and now whenever I put my modded Skyrim on the new SSD (Apacer Panther AS340), the game freeze upon loading a large exterior cell, every single time.

So I tried troubleshooting my modlist to no avail, until I copied everything to the HDD on the same system, the game runs smoothly, I copied everything to a different system (My laptop), the game runs smoothly. So I thought the problem was the new SSD and bought a new better M.2 SSD (Western Digital Black SN750), and put my game files on there, and the game still freeze upon loading cell!!! This only happens on heavily modded Skyrim SE and Fallout 4, other heavy open world games like The Witcher 3 or Black Desert Online with no mods can still run but experience some stutter, and also only happens on SSDs on this system, no where else.

If anyone could point me to the right direction, I thank you.

My system specs:
Motherboard: MSI Tomahawk B350
CPU: AMD Ryzen 5 1600 6 core 12 threads 3.2Ghz
GPU: Asus ROG Strix GTX 1060 Gaming 6G GDDR5
RAM: Gskill 16 Gb DDR4 2400Mhz (8Gbx2)
PSU: Acbel iPower G650 (Not an actual good PSU, but I've ran into no problem until this)
Drive 1: Apacer Panther AS340 SSD
Drive 2: M.2 Western Digital Black SN750
Drive 3: A Western Digital Blue HDD I don't remember the details of
 

ASK THE COMMUNITY

TRENDING THREADS