Skyrim graphic glitch

G

Guest

Guest
Hello there, I've had Skyrim for a while now and have had no trouble running it at a smooth 60fps.
It's been about a month since I last played it and now I'm getting this...


I am using a 6870 and have the latest version of AMD catalyst.
My other games run fine.
I've looked at other Skyrim graphic glitch threads and they all end with either driver updates or it's a different problem, please help me out here guys.
 
Solution
Yeah you have to turn off the game's AA if you don't want that problem. I've seen a lot of people posting about that. It has something to do with the latest Catalyst drivers if I recall correctly.
your getting artifacts. either update or roll back your drivers... check your temps. anything higher than 80 and your cooling is probably causing the artifacts and you need to adjust your fans power curve with msi afterburner...
if your temps are fine then either the drivers have become corrupted or some other component of the game has... but its most likely the driver.
 
G

Guest

Guest

Not likely to be a temperature issue, the GPU doesn't get hotter than about 65C when playing Skyrim. I noticed that when I use FXAA or no antialiasing there is no problem, I'm assuming that it's to do with using standard antialiasing rather than postprocessing or none at all.
This is frustrating because AA works fine in other games. Verified the integrity of the game cache in Steam.
Catalyst is set to application settings.
 

computer_noob

Distinguished
Feb 24, 2009
31
0
18,540
Yeah you have to turn off the game's AA if you don't want that problem. I've seen a lot of people posting about that. It has something to do with the latest Catalyst drivers if I recall correctly.
 
Solution
G

Guest

Guest

Ah, thanks.
Now I feel pretty foolish, I hadn't considered that the issue was specific to 12.3.
After your post I just Googled "12.3 catalyst Skyrim" and got this, well it seems like I just have to bear without AA for a while.
Thank you all.