Skyrim: High FPS problem?

Ry-Guy

Honorable
Jul 12, 2013
35
0
10,560
11
I just installed my new Zotac Geforce GTX 770 4gb graphic card. So my first move is to play Skyrim, of course. Everything looked amazing except when I rode on a horse it glitched out to a point where I couldn't move.

All my settings are set to max. I also noticed when I started to record, using Action! recording software, it drops the fps to 60 and the glitching stopped. So could having to high of a FPS cause problems? I've tried a lot of troubleshooting guides but to no avail. So is this a driver problem or am I missing something?

My monitor is an Asus VG248qe and is set to 144hz.
 
Skyrim has issues with framerates higher than 60FPS, that's why Vsync is always on in that game and can only be disabled in a config file. When they were doing the port, they obviously did not account for high refresh rate displays, so you get all sorts of physics glitches. Your best option would be to either set your refresh rate down to 60Hz when playing Skyrim, or to use a framerate limiter to cap your framerate at 60FPS for Skyrim.
 
Skyrim has issues with framerates higher than 60FPS, that's why Vsync is always on in that game and can only be disabled in a config file. When they were doing the port, they obviously did not account for high refresh rate displays, so you get all sorts of physics glitches. Your best option would be to either set your refresh rate down to 60Hz when playing Skyrim, or to use a framerate limiter to cap your framerate at 60FPS for Skyrim.
 

Pinhedd

Polypheme
Moderator


Skyrim has VSync enabled by default and it has to stay on or the phsyics engine and game clock will go haywire.
 

ASK THE COMMUNITY