Question Slots 1 & 2 work but whenever I do dual channel it just gives me no signal

NoGoodAnything

Prominent
Dec 28, 2020
16
1
515
0
Whenever I try to do dual channel the monitors will just give me no signal and a red light on my dram I have tried each stick there is nothing wrong with any of them I know this because they were in my computer before I upgraded to a new motherboard and CPU I heard that pin bending can be an issue and took a picture of this and wanted to know if this is the problem and if anyone can help me out because I want to put my 2 other sticks back in the computer.

Photo: View: https://imgur.com/CA1FBgO


Specs:
GPU: NVIDIA 3060
CPU: I-9 11900k
Motherboard: Asrock z590 pro4
Windows 10

Fixed: I winged it without a magnifying glass or anything I grabbed my trusty fork and was able to get the pin-up then I stabbed it a couple of times for good measure and was not able to properly seat it but got pissed and just said you know what maybe it works now and what do you know I have 4 sticks of working ram in my computer.
 
Last edited:

NoGoodAnything

Prominent
Dec 28, 2020
16
1
515
0
Based on that pic, it looks to be bent over completely backwards?

If so, that is going to be a hard fix.
I've fixed bent Intel pins before, but not bent at that level.
I have never tried fixing a bent pin before the motherboard is brand new so I don't even know how the pin got so bent.
 

NoGoodAnything

Prominent
Dec 28, 2020
16
1
515
0
Whenever I try to do dual channel the monitors will just give me no signal and a red light on my dram I have tried each stick there is nothing wrong with any of them I know this because they were in my computer before I upgraded to a new motherboard and CPU I heard that pin bending can be an issue and took a picture of this and wanted to know if this is the problem and if anyone can help me out because I want to put my 2 other sticks back in the computer.

Photo: View: https://imgur.com/CA1FBgO


Specs:
GPU: NVIDIA 3060
CPU: I-9 11900k
Motherboard: Asrock z590 pro4
Windows 10

Fixed: I winged it without a magnifying glass or anything I grabbed my trusty fork and was able to get the pin-up then I stabbed it a couple of times for good measure and was not able to properly seat it but got pissed and just said you know what maybe it works now and what do you know I have 4 sticks of working ram in my computer.

NOTE: It still gives me a red DRAM and BOOT light but it goes away in like a couple seconds.
 
Reactions: DRagor

NoGoodAnything

Prominent
Dec 28, 2020
16
1
515
0
That's normal, nothing to worry. Only when LED stays lit is signals a problem. Anyway, good job fixing it. Never heard anyone straightening pin with a fork! :)
I would not even call it straightening because It still looks obviously bent I literally feel like I did nothing just happy it works now will not be taking the CPU off anytime soon I can tell you that.
 

ASK THE COMMUNITY

TRENDING THREADS