Question Slow Ethernet speeds in Win 10. Not in Linux, so not an hardware problem

africsnail

Commendable
Jul 9, 2017
80
0
1,640
2
Hello,
I have been experiencing slow Ethernet speeds in Windows 10 (about 200 Mb/s), but on Linux I have installed I have full 500 Mb/s which our ISP guarantees.
Tested the speed using https://www.speedtest.net/ as well as torrent based speed test.

My MoBo: Asus ROG Maximus VIII hero
I have installed the newest drivers available for my board as well as tried older ones.

Thank you for any help
 

Ralston18

Titan
Moderator
What network adapter(s) is/are installed on your motherboard?

Check the network adapter's configuration settings. Speed and Duplex.

Ensure that only the wired network adapter is enabled. The wireless adapter, if present, should be disabled.

Are you able to run and post the results of "ipconfig /all" (without quotes) via the command prompt?
 

africsnail

Commendable
Jul 9, 2017
80
0
1,640
2
What network adapter(s) is/are installed on your motherboard?

Check the network adapter's configuration settings. Speed and Duplex.

Ensure that only the wired network adapter is enabled. The wireless adapter, if present, should be disabled.

Are you able to run and post the results of "ipconfig /all" (without quotes) via the command prompt?
I am using the onboard Ethernet adapter.
It automatically sets full duplex 1Gb/s so no problem here either.
I don't have any wireless adapter so I am sure it's running over Ethernet.

Result of ipconfig:
C:\windows\system32>ipconfig /all
Windows IP Configuration
Host Name . . . . . . . . . . . . : DESKTOP-JLCTBN8
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : Yes
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : home
Ethernet adapter Ethernet:
Connection-specific DNS Suffix . : home
Description . . . . . . . . . . . : Intel(R) Ethernet Connection (2) I219-V DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 192.168.0.165(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : 6.11.2019 10:17:26
Lease Expires . . . . . . . . . . : 6.11.2019 11:47:25
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DNS Servers . . . . . . . . . . . : 2606:4700:4700::1111 2606:4700:4700::1001 1.1.1.1 1.0.0.1
NetBIOS over Tcpip. . . . . . . . : Enabled

I am using 1.1.1.1 but it was same with google's 8.8.8.8 DNS
 

Botnus

Distinguished
Jun 10, 2012
90
1
18,665
10
I'd assume the ports on the switch/router you're using are set to the correct duplex and speed since they won't talk with the computer if not. Are you getting a lot of packet loss? Is there maybe EMI or crosstalk messing with the cables? How long are the Ethernet cables, and do they have any sharp kinks in them? Have you tried using a different port? Maybe switching the PC's Ethernet connections and seeing if the issue remains constant, or if the computers' speeds switch? Does the Windows PC share a port with another device?

I've seen this happen before, and it was an issue with the physical cabling. The setting was unique and not at all a home network though, so I'm just going up the OSI model, here.
 

Ketchup79

Notable
Aug 7, 2019
1,149
106
940
46
Cool. If you are running software affecting your network speed, such as ROG Game First software , or other devices on your network slowing you down, you might try getting a newer driver from the Intel website. They almost always have a newer network driver.
 

ASK THE COMMUNITY

TRENDING THREADS