Question Slow internet on one device, but gigabit service?

Mar 29, 2020
6
1
15
0
Long story short: 24 Mbps up and down on a Google Fiber 1000 Mbps internet service, only one device

Since a few weeks ago, my PC has been experiencing slow internet speeds. The service is Google Fiber (I'm in Nashville) 1000 Mbps. At one point, everything was normal, regularly testing at ~900 Mbps parallel. I first noticed after being out of town for a week that I was now hitting only 24 Mbps parallel. The weird part is that using the exact same network setup (same cables, network devices, etc) but with a different end device (say, my laptop's ethernet port) gets me normal performance.

Google's speed test gets me 24 Mbps up and down. Ookla gets me 35 Mbps up and down on single mode, 94 Mbps up and down on multi mode. These speeds are reflected in practical performance; downloads appear far slower than normal (Steam, Chrome, etc).

The only device connected directly to my Network Box (besides the fiber jack) is a Netgear ProSAFE GS108 switch, and connected to that is the affected PC (no other devices are connected to the switch). Cables have all been tested and are working. Again, if I swap out the affected PC with my laptop (same cables, switch, network box, etc) i get normal speeds. Issue persists whether or not wireless devices are connected.

The other weird part is that I did a network test via TotuSoft's LAN Speed Test, using the affected PC and my laptop as the two devices, both connected via LAN (affected PC behind the switch, laptop direct into the network box), and got very normal speeds, far more than 24 Mbps. So it appears this issue is strictly an internet thing.

Due to an unrelated issue (theoretically), I had Google tech support come out and replace all their hardware. This speed issue existed before, and it continues to exist after. Network is otherwise performing normally (no interruptions, good ping).

Things I've done include:
-Closing all running applications
-Windows update
-LAN adapter driver reinstall/update
-Disable P2P Windows update
-0% reservable bandwidth via gpedit
-Disable Windows auto-tuning
-Disable Large Send Offload (IPv4 and IPv6)
-ipconfig flushdns/release/renew

Network:
Google Fiber 1000 Mbps
Google Network Box GFRG200
Google Fiber Jack GFLT110 (i believe, Google isn't being helpful)

PC:
ASRock Z390 Taichi via Intel I219-V adapter, driver ver. 12.18.9.10
EVGA SuperNOVA 1000 P2
Windows 10 Pro 10.0.18362 Build 18362

Thanks in advance. First time posting. Tried to follow the stickies as close as possible. Also couldn't find any duplicate posts that solved this issue.
 
Second the suggestion to test using a linux live cd/usb. If you get full speeds there to the same speedtest sites, it's something in windows.

I know there were a couple of threads about this recently where there is a windows setting that tries to optimize/maximize ethernet speeds and if they are not set correctly they end up causing speed issues like this.
 
Mar 29, 2020
6
1
15
0
Currently in the weird process of not being able to find any usb sticks laying around, so I'll report as soon as I test out Linux.

EDIT: Found one, but for resons that should be obvious, this download will take a bit. Should have results in an hour.
 
Last edited:
Mar 29, 2020
6
1
15
0
Sorry, that took way longer than I thought. Ran into some unrelated issues, but I got my results.

Using Linux Mint, my results were:
Google: 81 down, 86 up
Ookla (single): 27 down, 90 up
Ookla (multi): 90 down, 94 up

I ran each test a few times. So not wildly different than before, so I'm guessing that rules out Windows?

Second the suggestion to test using a linux live cd/usb. If you get full speeds there to the same speedtest sites, it's something in windows.

I know there were a couple of threads about this recently where there is a windows setting that tries to optimize/maximize ethernet speeds and if they are not set correctly they end up causing speed issues like this.
Happen to have links to those threads? As I said, I had some back luck finding the right stuff myself.
 
Mar 29, 2020
6
1
15
0
UPDATE: I'm reasonably certain I checked this earlier, but looking at my Google Fiber network settings, the affected PC's configuration page lists its status as 100 Mbps.

I've checked both (Network and Internet>Status>View Your Network Properties) and the status of my network adapter, and both specify 1000 Mpbs/1.0 Gbps. I've reset the adapter by disabling and re-enabling, release/renew a second time, and Google still believes the connection is 100 Mbps.

Since I (may have) ruled out Windows, I'm going to contact Google to ask. Again, I don't believe this was the case before, but stranger things have happened. I will return with results as soon as possible.

EDIT (12:00 am CST): What are the chances of a cable going bad in the middle of troubleshooting speeds? In any case: cable replaced, but the issue persists. Haven't called Google yet, but I did notice something even more strange: Google's speed test (via M-Lab) and Ookla are still behaving slowly, but the Google speed test via speed.googlefiber.net is aces, ~950 Mbps down and up. I've deleted the cache in Chrome and I still get the slow speeds, and as I said, this issue is affecting actual performance in applications. Stay tuned for updates, and I'm still open to new ideas.
 
Last edited:
Mar 30, 2020
1
2
15
0
Just had a very similar problem to you. Same problem and funky results with a perfect connection to the router and perfect functionality on other devices; I even have the same Network Adapter. A lot of other threads out there on the internet suggest DISABLING Windows Auto-Tuning, and having seen it already disabled on my computer I thought nothing of it. However, ENABLING it is what fixed my issue.

Run CMD as admin
Enter:
netsh int tcp show global
Look for "Receive Window Auto-Tuning Level:" and toggle it to the opposite state

To enable enter:
netsh int tcp set global autotuninglevel=normal
To disable enter:
netsh int tcp set global autotuninglevel=disabled
I jumped through a million hoops trying to figure this out only to have the opposite of what most people suggest work for me. According to Major Geeks this should be set to normal unless your router or adapter doesn't support it.

Hope this helps. It marked the end of a long and arduous 5 hour journey for me :)
 
Reactions: SamirD and OODUMB
Mar 29, 2020
6
1
15
0
Just had a very similar problem to you. Same problem and funky results with a perfect connection to the router and perfect functionality on other devices; I even have the same Network Adapter. A lot of other threads out there on the internet suggest DISABLING Windows Auto-Tuning, and having seen it already disabled on my computer I thought nothing of it. However, ENABLING it is what fixed my issue.
Holy smokes, that did the trick. I feel like it was enabled at one point, but it was certainly disabled now, as you noted that others suggested it. I turned it on, and did another release/renew (it's a reflex by this point), and things are now performing normally. Slightly below expectations (web tests at about 600-700 Mbps), but that's likely the result of high volume traffic these last few weeks. And the speed via speed.googlefiber.net is still aces, relative to just before your recommendation.

I might yet contact Google, especially if this occurs again, but I'll definitely report back if this crops up again in the near future. Thanks again!
 
Reactions: SamirD

ASK THE COMMUNITY

TRENDING THREADS