Question Slow internet speed in windows

Triasis ghosh

Reputable
Feb 17, 2019
54
2
4,535
0
I have a PC, dual booted with Windows 10 and Ubuntu. My wifi card is from intel and supports wifi 6. All was running perfectly fine. Suddenly speed in my windows become very low, but when checked in ubuntu, it's working fine. Every other devices like laptops , phones are getting full speed. I tried with driver reinstall, driver update, wifi device uninstall reinstall, system restarts etc but nothing is working. My internet speed at router is 100 Mbps, other devices are receiving 85-90 Mbps. But in my pc , in windows the speed barely touches 10-15 Mbps. Everything on internet is slugish, except YouTube videos. The YouTube videos are streaming in even at 8k without much issue. I really can't figure out what is happening with it.

My PC is only 1.5 months old with following specs
Intel i5 12400
MSI PRO B660M A WIFI
16 GB RAM(8 x2)
500 gb wd sn570 ssd
1 tb hdd
 
i would go into control panel, device manager find the network device.
right mouse click for properties, bring up the advanced tab and look at the settings:
see if there is a setting for transmit power and set it to the highest
value, check other settings also. like thoughput booster.

next I would check to see what band it is using and see if you have contention on that band from a nearby router. each router band overlap can drop bandwith by 10 to 20%
I generally use WIFIAnalyzer app on my android phone to check for other routers. (wow 74 router can be seen in my condo right now) I use the app to find a channels that have few router on it and routers that are further away.

windows has been doing a lot of changes to save power. I would not be surprised if they reduced the transmit power. in USA fcc made regulations to limit the transmit power of devices. To save energy but to also reduce the effects of interference between devices. A few years ago I had to get a new router that operated 5ghz band since the condo next door (20 ft away) got a new high transmit power nighthawk router so he could drown out other signals so he could get better wireless speeds. I just used the new band on a unused channel and he just fights with other routers on a crowed band and channel. FCC want to reduce the transmit power to reduce this type of problem. regulations are in effect for the router, new ones needed for the pc transmitters. going to low power is better for everyone to limit interference (1/ (radius ^2)) function
 
Last edited:

Triasis ghosh

Reputable
Feb 17, 2019
54
2
4,535
0
Do you have the antennae attached to back of motherboard?
Are you using wifi 6 on board or have a card?
https://www.msi.com/Motherboard/PRO-B660M-A-WIFI-DDR4/support#driver
might be newer drivers here but WIFI drivers on motherboard website are from last month
https://www.intel.com.au/content/www/au/en/support/intel-driver-support-assistant.html
The wifi card is capable of wifi 6. I personally use a wifi 4 dual band gigabit router with 100 Mbps plan. The issue got automatically resolved upon the next morning after I posted it here. But today it again came back.
 

Triasis ghosh

Reputable
Feb 17, 2019
54
2
4,535
0
i would go into control panel, device manager find the network device.
right mouse click for properties, bring up the advanced tab and look at the settings:
see if there is a setting for transmit power and set it to the highest
value, check other settings also. like thoughput booster.

next I would check to see what band it is using and see if you have contention on that band from a nearby router. each router band overlap can drop bandwith by 10 to 20%
I generally use WIFIAnalyzer app on my android phone to check for other routers. (wow 74 router can be seen in my condo right now) I use the app to find a channels that have few router on it and routers that are further away.

windows has been doing a lot of changes to save power. I would not be surprised if they reduced the transmit power. in USA fcc made regulations to limit the transmit power of devices. To save energy but to also reduce the effects of interference between devices. A few years ago I had to get a new router that operated 5ghz band since the condo next door (20 ft away) got a new high transmit power nighthawk router so he could drown out other signals so he could get better wireless speeds. I just used the new band on a unused channel and he just fights with other routers on a crowed band and channel. FCC want to reduce the transmit power to reduce this type of problem. regulations are in effect for the router, new ones needed for the pc transmitters. going to low power is better for everyone to limit interference (1/ (radius ^2)) function
Tried the settings friend, but it's not helping.😥
 

Triasis ghosh

Reputable
Feb 17, 2019
54
2
4,535
0
i would go into control panel, device manager find the network device.
right mouse click for properties, bring up the advanced tab and look at the settings:
see if there is a setting for transmit power and set it to the highest
value, check other settings also. like thoughput booster.

next I would check to see what band it is using and see if you have contention on that band from a nearby router. each router band overlap can drop bandwith by 10 to 20%
I generally use WIFIAnalyzer app on my android phone to check for other routers. (wow 74 router can be seen in my condo right now) I use the app to find a channels that have few router on it and routers that are further away.

windows has been doing a lot of changes to save power. I would not be surprised if they reduced the transmit power. in USA fcc made regulations to limit the transmit power of devices. To save energy but to also reduce the effects of interference between devices. A few years ago I had to get a new router that operated 5ghz band since the condo next door (20 ft away) got a new high transmit power nighthawk router so he could drown out other signals so he could get better wireless speeds. I just used the new band on a unused channel and he just fights with other routers on a crowed band and channel. FCC want to reduce the transmit power to reduce this type of problem. regulations are in effect for the router, new ones needed for the pc transmitters. going to low power is better for everyone to limit interference (1/ (radius ^2)) function
Tried the settings friend, but it's not helping.😥
 

ASK THE COMMUNITY

TRENDING THREADS