Question Slow internet speed only one computer in a network...

jon96789

Commendable
Aug 17, 2019
410
49
1,740
15
I have a home network with three PCs running Windows 10 Pro, two laptops connected via Wi-Fi and my desktop connected via ethernet to a Netgear 1900 router. Windows shows that my total internet usage was about one gigabyte in the past 30 days.

My internet speed suddenly dropped one day from 200 mb/s to 30 mb/s. I thought my ISP (Spectrum) was throttling me but the two laptops are unaffected. I also contacted Spectrum and they determined the issue was with the affected PC but do not know what is causing the problem. I changed the router, ethernet cable and the network card with no success. I also connected my desktop directly to the modem bypassing the router and still no luck. I checked for any updates on the day the speed dropped and nothing was installed or updated that week. I also ran Malwarebytes Pro and Norton 360 shows nothing infecting the PC. A registry scan shows nothing out of order. I booted the computer in safe mode and the problem persisted. I cleared my cache with no luck. i tried Google Chrome, Firefox and Microsoft Edge with no success. I also changed my DNS to Google DNS. I also use VPN and it has no effect to the speed.

I did notice one odd thing. I live in Hawaii and if I run a Speedtest to any local server in Hawaii, the internet speed shows 200 mb/s. But if i run Speedtest to any other server outside Hawaii (e.g. continental U.S. or other country), the internet speed drops to 30 mb/s.

Any suggestions would be appreciated.
 

ttower2020

Reputable
Nov 5, 2018
419
82
5,090
83
What speed are the Laptops running at? Have you tried connecting the Desktop to the WiFi? It wouldnt make a ton of sense, but if the WiFi is working to the laptops, and the Ethernet to the desktop isnt, then its worth trying to connect the desktop to the WiFi. If the desktop still runs slower than the laptops on WiFi, then there is a larger issue with the desktop, if the WiFi performs like normal, then there is probably an issue with the Ethernet somewhere, even though it seems you would have already tried most things I would suggest. external to the PC.
 

jon96789

Commendable
Aug 17, 2019
410
49
1,740
15
Thanks for the response. The laptops are streaming at 200 mb/s over wifi. My desktop does not have wifi capability. I am planning to go to BB and buy a wifi dongle and see if that changes anything, although I doubt it. Like i mentioned, if i connect the ethernet cable directly to the Arris modem bypassing the router, the slow speed is still there, so sometrhing must have changed on my desktop. Running in safe mode bypasses all non-essential services and startups and the problem persists, so something must have changed somewhere.
 

jon96789

Commendable
Aug 17, 2019
410
49
1,740
15
I connected a USB Wi-Fi dongle to the PC. Internet speed same at 25 mb/s so it has to be something on the PC... What I do not understand is that connecting to distant servers has such a radical drop in speed compared to local. I would think it has nothing to do with the hardware in that case.
 

jon96789

Commendable
Aug 17, 2019
410
49
1,740
15
Connected another computer to the router via ethernet. Speed was a normal 200 mb/s, so it has to be something on the desktop that is screwing up its connectivity...
 

jon96789

Commendable
Aug 17, 2019
410
49
1,740
15
I ended up installing Windows 10 from scratch which took the whole day. That fixed the problem but other issues popped up. Adobe Elements 2020 would not install as it is "obsolete". I need to purchase Elements 2021 or 2022. I believe that 2022 requires Windows 11. The biggest issue is that I lost my MS Office Professional activation code. Windows no longer stores activation codes for MS Applications in the registry. so that really sucked, I will have to buy MS Office 2021. If anyone can figure out what happened, i would be happy to know.

The sad thing is I absolutely know I backed up an image of my PC build after I installed everything the first time around but I could not find it. I will make sure to make another image after everything settles down.
 

ASK THE COMMUNITY

TRENDING THREADS