Question Slow internet via cable on only one computer

Jan 14, 2020
3
0
10
0
I'm having problems with my internet speed on one desktop computer (wired through LAN cable). Web pages won't load most of the time (site can't be reached) or eventually do after many refreshes and wait time. All other computer via WIFI work great. I've tried using a laptop on that computer's LAN line (whilst disabling WIFI) and internet works great and fast. So the problem isn't the cable or the modem or the router (i think). I've tried using a web based internet speed test and if the page loads, speed is fine and as expected on all computers. I'm stumped. I've tried to ping a website using the CMD.exe and I get a "ping request cannot find host." If I ping 8.8.8.8 it works without losing any packets.

Windows 7, using Chrome (or firefox)

Thanks for the help!
 

stonecarver

Upstanding
Nov 18, 2019
351
48
240
15
Sometimes an easy fix it to go to your Device manager and find your nic card and uninstall it But if it asks do you also want to delete driver say 'NO" after it's uninstalled go up to pull down tab while your in Device Manager and scan for hardware changes and it will put a fresh copy of your nic driver on.

Sometime driver just gets stupid and needs a kick.
 
Reactions: Markalark
Jan 14, 2020
3
0
10
0
Sometimes an easy fix it to go to your Device manager and find your nic card and uninstall it But if it asks do you also want to delete driver say 'NO" after it's uninstalled go up to pull down tab while your in Device Manager and scan for hardware changes and it will put a fresh copy of your nic driver on.

Sometime driver just gets stupid and needs a kick.
That seems to have done the trick!
Thanks a bunch Stonecarver
 

ASK THE COMMUNITY