Slow login - 20-30 seconds

cskoler

Distinguished
Oct 19, 2011
195
0
18,690
3
Hello,
I've been having some issues logging in lately to my recently-built computer. For the first several days, boot times were great (thanks to an SSD) and login took about 2 seconds. A couple weeks ago, though, it started taking 20 or more seconds to log me in. Initial boot times were still great, but it would hang on the "Welcome" screen afterward. I couldn't think of any big programs that I added that would have caused this or anything like that. I've looked through and haven't been able to find anything.
Now, after some google searches, I did come across an issue a bunch of people had been having where if your desktop background was a solid color, login times would go up, similar to the issue I'm having. The only issue is, my background isn't, and hasn't ever been, a solid color; it's a JPEG image, which supposedly never caused the login problem. I actually tried installing the hotfix that Microsoft released nonetheless, but to no avail.
I tried a registry fix, too, adding a "DelayedDesktopSwitchTimeout" file to the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System directory. This was not successful either.
So I'm stumped. I don't know what it could be.
If anyone has any ideas, input would be greatly appreciated. Thanks.


-Charlie
 

Saga Lout

Titan
Moderator


Press your Windows key and R together then in th eOpen box, type msconfig then press Enter.

Click the StartUp tab and untick everything except your AV and Firewall, click Apply and OK your way out. Restart then tick "Don't show this message again" and click OK then restartagain and time the startup.

You will not have made any changes you can't reverse.

 

cskoler

Distinguished
Oct 19, 2011
195
0
18,690
3

No luck.
I do want to clarify, though: I'm getting slow logins, not startups.
 

cskoler

Distinguished
Oct 19, 2011
195
0
18,690
3

Again, nothing. I could be wrong, but I get the feeling that this isn't being caused by startup services and programs, but some sort of other issue.
 

Saga Lout

Titan
Moderator


If you hit Control, Shift and Escape together when this is happening, to bring up the Task manager, that could show you what's eating the most resources. Click the heading of the CPU column to bring the highest users to the top of the list.

 

nikorr

Champion
Moderator

Hi cskoler,

Try this,


Article ID: 977346 - Last Review: November 9, 2011 - Revision: 7.0

The Welcome screen may be displayed for 30 seconds during the logon process after you set a solid color as the desktop background in Windows 7 or in Windows Server 2008 R2

http://support.microsoft.com/kb/977346

Hotfix Download Available

http://support.microsoft.com/hotfix/KBHotfix.aspx?kbnum=977346&kbln=en-us
 

cskoler

Distinguished
Oct 19, 2011
195
0
18,690
3

I did try this, and had no luck. Read the original post.
 

cskoler

Distinguished
Oct 19, 2011
195
0
18,690
3

Yes, I have. The one thing that I didn't try, though, was disabling the Desktop Window Manager. I know that controls the whole aero interface and effects, but is there a way I could disable it merely as a startup program and then have it start on its own afterward? Maybe I don't know what I'm talking about. I just wanna fix this.
 

cskoler

Distinguished
Oct 19, 2011
195
0
18,690
3

The Desktop Window Manager comes to the top. Other than that, it's a bunch of meaningless stuff.
 

Similar threads


TRENDING THREADS