Question Slow on only one device, my PC. Help!

Aug 12, 2020
3
0
10
0
I have searched the internet high and low for solutions to this issue I am having with my connection speed and I've come up with nothing. I've gone back and forth with Trendnet (TEW-809UB is my adapter model) support, and after 2 weeks, we've only determined it's not the poor adapter's fault. I've checked and double checked every adapter configuration option and I've gone through every setting in my PC. I'm ready to throw hands with God himself.

Every device in my household gets 100+ Mbps upload and download speeds except my PC, which only gets around 20 Mbps each way. Ethernet is not an option, and accessing router settings will be a unique challenge, due to my boomer stepfather.

PC Specs:
AMD Ryzen 5 3600 CPU
MSI Radeon RX5700XT GPU
MSI B450 Tomahawk Max MOBO
Trendnet TEW-809UB Wireless Adapter
EERO Mesh Wifi system
Luck, nada.

Worth noting, I've already made sure I don't have AMD QuickStream, which seems to be a common problem for AMD rigs. I've also disabled any streaming functions in the AMD software. All drivers for all pieces of hardware are also up to date.

Thanks!
 

kanewolf

Titan
Moderator
I have searched the internet high and low for solutions to this issue I am having with my connection speed and I've come up with nothing. I've gone back and forth with Trendnet (TEW-809UB is my adapter model) support, and after 2 weeks, we've only determined it's not the poor adapter's fault. I've checked and double checked every adapter configuration option and I've gone through every setting in my PC. I'm ready to throw hands with God himself.

Every device in my household gets 100+ Mbps upload and download speeds except my PC, which only gets around 20 Mbps each way. Ethernet is not an option, and accessing router settings will be a unique challenge, due to my boomer stepfather.

PC Specs:
AMD Ryzen 5 3600 CPU
MSI Radeon RX5700XT GPU
MSI B450 Tomahawk Max MOBO
Trendnet TEW-809UB Wireless Adapter
EERO Mesh Wifi system
Luck, nada.

Worth noting, I've already made sure I don't have AMD QuickStream, which seems to be a common problem for AMD rigs. I've also disabled any streaming functions in the AMD software. All drivers for all pieces of hardware are also up to date.

Thanks!
Do you know if the EERO has the same SSID name for 2.4 and 5Ghz?
Do you know if you are connecting to 2.4Ghz or 5Ghz signal?
 
Aug 12, 2020
3
0
10
0
Do you know if the EERO has the same SSID name for 2.4 and 5Ghz?
Do you know if you are connecting to 2.4Ghz or 5Ghz signal?
Our EERO system pushes both 2.4 and 5Ghz under the same SSID. My adapter seems to switch between them on it's own periodically.
 
Aug 12, 2020
3
0
10
0
That probably means that your still getting a weak 5Ghz signal. Your PC drops to 2.4Ghz and the performance is poor.
Hm. I'm only on the other side of the wall from my router and my laptop, being literally 18 inches from where my adapter is hung on the wall, gets 100+ Mbps each way. What's the deal? What are possible problems, and how can I fix them? I've updated all my drivers and everything.
 

ASK THE COMMUNITY

TRENDING THREADS