[SOLVED] Slow PC with Semi Pro Config Issue

Dec 5, 2020
2
0
10
0
I built a system with some parts from my OLD PC & some upgrades over time.

I run design software (AI & PS) & chrome developer browser on Win10 Pro [redacted]

My Issue - PC performs below average than what it is supposed to, with 3-4 tab and 1 YouTube tab slows it down and i can see lag & sometimes it gets stuck too for a 3-4 seconds

Config -
Processor -
Intel(R) Core(TM) i3-6098P CPU @ 3.60GHz 3.60 GHz
MotherBoard - ASUS H170M PLUS
Graphics Card - Nvidia GT GForce 710 2GB
SMPS - iBall High Performance, High-Efficiency 500W Peak Power Supplyiball
3 Hard Drives -
  1. SSD OS - Samsung 970 evo plus 500gb
  2. SSD - WD 120gb Green
  3. HDD - Seagate 500gb
RAM - 4 Slots
  • 1nos Zion 8GB DDR4 PC 2133 UB Dimm Desktop RAM
  • 1nos G.SKILL Ripjaws V Series 8GB 288-Pin DDR4 SDRAM DDR4 2400 (PC4 19200)
  • 2nos Corsair Vengeance LPX 8GB DDR4 3000
Anyone with any experience or any guidance, please help.

I have tried optimizing windows 10 with this PowerShell command too
View: https://www.youtube.com/watch?v=dO30OnTsJhk


I am frustrated and need help.
 
Last edited by a moderator:

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

First off, there are a lot of things wrong with your platform. You're working with a PSU that is known to ruin everything it's connected to(and start fires to burn houses down). You're also mixing and matching sticks of ram, take all of the out and only use the 2 sticks of Corsair rams.

As for your OS, where did you source the installer from?
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

First off, there are a lot of things wrong with your platform. You're working with a PSU that is known to ruin everything it's connected to(and start fires to burn houses down). You're also mixing and matching sticks of ram, take all of the out and only use the 2 sticks of Corsair rams.

As for your OS, where did you source the installer from?
 
Dec 5, 2020
2
0
10
0
Welcome to the forums, newcomer!

First off, there are a lot of things wrong with your platform. You're working with a PSU that is known to ruin everything it's connected to(and start fires to burn houses down). You're also mixing and matching sticks of ram, take all of the out and only use the 2 sticks of Corsair rams.

As for your OS, where did you source the installer from?
Hi, Ok!

Will try to change the PSU asap.
Will follow that advice for the ram.

The Computer store guy installed win 10 pro. not sure of the source.
 

ASK THE COMMUNITY

TRENDING THREADS