Question Slow signal detection through DiplayPort ?

7medd

Prominent
Nov 14, 2020
57
9
545
4
I have an MSI 251rx bought a month ago. I noticed that if I connect it to my PC through HDMI, it works fine. If I use DP it is slow to detects signal . It starts to display when boot is over it reaches desktop. Also this comes with a red VGA signal on mobo. Everything works fine afterwards. No performance flaws at all.

This doesnt happen when I reboot PC (monitor doesnt turn off) and then I can see bios access options .
I tried to change monitor settings , disable Eco mode , disable enable autoscan, I manually installed the driver from official site, change DP port on GC ... no success
I cant find another DP cable in my country to try it.

https://postimg.cc/bDVXd7Kg

I had a 144Hz monitor before, connected through DP and never had a this problem.

Any clue ?
 
Last edited:
I have an MSI 251rx bought a month ago. I noticed that if I connect it to my PC through HDMI, it works fine. If I use DP it is slow to detects signal . It starts to display when boot is over it reaches desktop. Also this comes with a red VGA signal on mobo. Everything works fine afterwards. No performance flaws at all.

This doesnt happen when I reboot PC (monitor doesnt turn off) and then I can see bios access options .
I tried to change monitor settings , disable Eco mode , disable enable autoscan, I manually installed the driver from official site, change DP port on GC ... no success
I cant find another DP cable in my country to try it.

https://postimg.cc/bDVXd7Kg

I had a 144Hz monitor before connected through DP an naver had a similar problem

Any clue ?
It sounds like the monitor is the issue, Om monitors with drivers have issues with not display till a driver wakes it up another words it's working the way it knows, the driver initialized the screen via dp normal via hdmi
 
Reactions: 7medd

7medd

Prominent
Nov 14, 2020
57
9
545
4
It sounds like the monitor is the issue, Om monitors with drivers have issues with not display till a driver wakes it up another words it's working the way it knows, the driver initialized the screen via dp normal via hdmi
Problem is RMA is not availble in my region either .. I thought it would be a firmware problem of the monitor and might be solved through update or so .. but I cant find how to do this.
 

ASK THE COMMUNITY