Question Slow SSD data transfer speed

Jun 21, 2019
4
0
10
0
Hey guys! Recently i bought my first brand new SSD - Crucial MX500 250 gb. I was really busy at the time so i left it in the box for two weeks because i had no time to install it. Finally two weeks ago (month after the purchase) i decided to give it a try. I've installed and played few games and the drive seemed to work pretty well even though my Windows was installed on my old HDD. Yesterday i decided to install my system on the ssd and it worked ok (startup takes about 12 seconds) so i've only installed all the drivers and decided to test it with a crystaldiskmark, the results were terryfing. SSD's transfer speed was comparable to my 7 years old HDD !. I tried a lot of solutions from updating bios and device firmware, checking if the ahci mode is turned on (it was all the time) same with s.m.a.r.t and all that stuff. I'm running out of idea what can be wrong...
PC specs:
MOBO: GA-B250m-D3h
CPU: i5 7500
RAM: GoodRam 8GB (2x4GB) 2133MHz
PSU: Corsair CX550M

CrystalDiskInfo: View: https://imgur.com/a/RvMxlGc

CrystalDIskMark: View: https://imgur.com/a/FuxNEzC

AS SSD: View: https://imgur.com/a/eCGdGTx
 
Jun 21, 2019
4
0
10
0
Tried all ports on my mobo with 3 different cables even with only SSD connected and it still doesnt work properly. I will connect it to my friends pc today and ill let you know
 

seanwebster

Contributing Writer
Editor
Aug 30, 2018
63
14
545
1
Hmm, not quite sure myself. You can try clearing CMOS to reset the board, but that is usually to just fix PCIe drive lane allocation issues. It may help for your SATA drive, but doubtful.

Try disabling power savings features in the UEFI?
 
Jun 21, 2019
4
0
10
0
Every power saving feature in my bios is probably turned off. Well at least the options i was able to find. Here are my SATA port settings, maybe you'll find anything suspicious. What is aggresive LPM ? Sorry for the quality but i couldnt take any ss of the bios.



EDIT: I've disabled the aggresive lpm support and it did nothing to be honest. Also i've tried to disable integrated VGA but it also had no affect on the ssd performance
 
Last edited:

seanwebster

Contributing Writer
Editor
Aug 30, 2018
63
14
545
1
The CPU & chipset power savings features. Disable C-states, P-states, cool n quite mode. It helps get better benches, but I don't think it can help this situation. I think for this you need to test it in another system or RMA for another.
 
Jun 21, 2019
4
0
10
0
Ok, the drive works well on my friends pc that means that something is wrong with the mobo i guess. Ill try messing with the bios. Do you have any idea what causes that kind od problems?
 

ASK THE COMMUNITY

TRENDING THREADS