Slow transfer speed over Gb LAN to USB3 external HDD

embeathome

Honorable
Mar 27, 2013
4
0
10,510
0
Hello,

since 2-3 weeks my transfer speed from from desktop machine to my HTPC dropped to approx 30 Mb/sec from 100-110Mb/sec few weeks ago. I have following setup at home:

- HTPC with SSD - OS installed only, 1 external HDD WD Elements (1TB) with media for kids
- Desktop PC with SSD for OS and additional HDDs (7200Rpm)
- FreeNas server with SSD and 6 WD Red, 16GB RAM
- all 3 pcs have same Gb NIC Intel 1000 CT
- all PCs conncted over Gb LAN through Gb router and Gb switches

Until 2-3 weeks everything worked fine, transfer between PCs was 100-110 MB/sec.

I tried everything possible including:

- turning on Jumbo frames
- set 1Gb full duplex
- disabling Larg Sent Offload IPv4 and 6
- connecting PCs directly bypassing switches and router

Nothing helped. Then I tried transfer from OS SSD on Server and Desktop PC to SSD on HTPC. And also from OS SSD on desktop to HTPC. And here transfers increased back to normal 110Mb/sec!

So problem here was/is desktop PC and transfer from its 7200Rpm HDD. Don't understand why but its like that. Network is OK, cables OK, switches OK.

So the main problem is transfer from SSD to HTPCs WD Elements which is connected to HTPC over USB3. No matter what I do here, speed is still slightly above 30Mb/sec. I am talking about transfer of huge files, over 10GB.

WD Elements has no errors, it is defragmented. HTPC has very good hardware inside.

Any ideas what could be a problem here? All the netwrk worked fine few weeks ago but suddenly speeds dropped down.
 

ASK THE COMMUNITY

TRENDING THREADS