Question slow turn maybe with controller on pc?

Feb 1, 2021
1
0
10
0
Hey everyone this is my first post on the forums. So i been playing COD Cold war using my scuff ps4 controller. For the first few month I sucked I couldn't figure out what was wrong.
I OC my controller felt a little better but still felt like there was some sort of input lag or sluggish aim/movement. I played mw fine with ds4 with PC and controller never had any issues.
Until a few days ago i reset my scuff plugged it back in and it felt amazing super snappy, "twitchy" in a sense and it worked like that all day played great. Felt like a entire new game, went to play the following day it once again felt sluggish. I swore it was the controller so I ordered a brand new one.

It worked for a day or two then same thing got sluggish. So now i knew it wasn't the controller side of things. The controller is reading 0.5ms. On Ds4 so there shouldn't be any input delay.
Now i was trying to see what else it could be I've tried everything. I would reset it, it would work for half a game then start to get slower as the game went on. Now it only works for about 15 seconds then gets slow once again.

The things I've done to try and resolve it
  1. New controller/New usb cord tried all different ports.
  2. updated all drivers software even brand new windows install.
  3. Changed graphics on Nvidia to make it fell like less g sync/ v sync play on lowest setting ingame
  4. changed and tried all deadzones in game and with Ds4. Ds4 on and off
  5. disabled fastboot
  6. read if you lower frame rate it can help i capped it at 120 still same thing.
I have no idea what it can possibly be I also had a friend who played on it said he felt the same thing it feels off, He described it as feeling "tight" as you had to pull the stick all the way over to achieve the same movement in game.
I play on a 144Hz monitor
Pc Specs are.
AMD Ryzen 7 2700X Eight Core Processor 3.70GHz 16GB Ram
Nvidia GTX 1080
ASrock B450M/ac

Sorry as I'm not very computer savey yet still learning but this is very frustrating chasing this problem makes the game unplayable.
If anyone has any insight as to what it may be please let me know!!
 

ASK THE COMMUNITY

TRENDING THREADS