Question Slow WiFi but fast modem ?

May 16, 2021
1
0
10
0
Hi guys, I’m in desperation here and have searched the internet but found now solutions. I only have one more thing to try and that’s to buy a new modem but I feel like that might not solve the problem.

heres the situation:
Xfinity internet at 100mbps max
Modem is a netgear CM400
Router is a mesh Eero wifi6

-when I connect my laptop to the modem via Ethernet, it won’t recognize that it’s connected… weird.
-When I connect the modem to the router and then hardline from the router, laptop gets 100mbps
-when I check in the eero app to run a speed test, eero device says it’s getting 100mbps from the modem.
-when I run a speed test on any device connected to the wifi, I’m only getting around 11mbps ?

what’s the deal? How do I fix this? Do I have to get a new modem? I don’t think is the router.

by the way I live in a 700sqft apt so reception isn’t an issue, the modem and router sit about 10ft away from the tv or anything else. All the wifi test was me sitting next to the router.

Help please!!!!
 
You can connect your pc directly to the modem but in most cases you must reboot the modem every time you change what is plugged into it. Cable modems tend to lock onto the first mac address they see and not change until you reboot.

The wifi speed is negotiated so your end device is 1/2 the connection. Look in the status and see the "speed" it says it connected at. This is not actually the speed it is what is called a MCS value, and it represents how the data is being encoded. You only get a small fraction of this number but 11mbps is extremely slow. This could be some strange issue with wifi6. There are still bugs in both end device drivers and router firmware.

Maybe try to force it to use the other radio. It would be highly unlikely both the 2.4g and 5g radios would fail if it was a hardware issue.
 

ASK THE COMMUNITY