[SOLVED] So my PC doesn't run slow but my frames are always horrible

Jan 4, 2022
2
0
10
0
I have been dealing for the past few days with really bad frame drops, where i used to run around 75-100 on ETS 2 and 80-120 on Valorant, i'm now running 6-23 FPS, i cleaned my PC completely and updated my drivers. I Cant even run Minecraft properly...

Are my specs out of date? heres a list

Motherboard : MSI Z97
Graphics Card: MSI Geforce GTX 970
CPU : Intel Core I5-4690k
RAM : 24gb RAM
Storage : 314GB free space, 180 on my system and 134 on a separate SSD

Please help ahahah
 
your 4th gen i5 is ~7-8 years old,
as is the GTX 900 GPU.
this is definitely considered out-of-date when discussing gaming systems.

your odd configuration of RAM, 24GB, usually means that you have mixed kits.
even if they are the exact same make/model, if they have not been properly tested and packaged together this can also lead to performance issues.

you also don't mention what temperatures you are reaching when running games.

why you would all of a sudden have worse performance can be any number of things though;
OS corruption, temperature throttling, malfunctioning graphics card, etc...

what make/model of power supply are you using and how long has it been in use?
 
your 4th gen i5 is ~7-8 years old,
as is the GTX 900 GPU.
this is definitely considered out-of-date when discussing gaming systems.

your odd configuration of RAM, 24GB, usually means that you have mixed kits.
even if they are the exact same make/model, if they have not been properly tested and packaged together this can also lead to performance issues.

you also don't mention what temperatures you are reaching when running games.

why you would all of a sudden have worse performance can be any number of things though;
OS corruption, temperature throttling, malfunctioning graphics card, etc...

what make/model of power supply are you using and how long has it been in use?
 
Jan 4, 2022
2
0
10
0
I did buy a different Ram, I usually ran 2x4gb but now I have 2x4gb and 2x8gb ram in my PC, the power supply is a 600W Corsair PSU, and I’ve had it since I built the pc years ago, I noticed on my task manager my feeds whenever I ran it would use Very High amount of power usage, I would also have Power cuts in my PC which lead me to think maybe my power supply is broken and not providing enough power to my CPU or PC alone. And my temperatures vary, they’re all usually normal running temps unless it’s a bigger game then they get slightly high but nothing dangerous
 

ASK THE COMMUNITY