Question so my ram speed is 1200mhz but says 2400mhz in bios help?

Jan 10, 2020
23
2
15
0
when i go in task manger it says its going 1200mhz and i tired changing it in bios and it just set even lower how can i get it to 2400mhz like i bought its a320m hdv r3.0 MOBO.
 

EndEffeKt_24

Notable
Mar 27, 2019
443
104
940
25
DDR stands for "double data rate" so programs like task manager or cpuz or ryzen master will report the actual frequency of the module which is half the advertised speed.
1200 mhz is the correct frequency for your 2400 ddr4 module.
 
Reactions: NightHawkRMX

NightHawkRMX

Illustrious
Jan 10, 2020
23
2
15
0
is going that speed isn't it anyway so no need to reseat it right? it will run the same if i reseat it or not?
 

Ferimer

Distinguished
Aug 19, 2011
349
14
18,795
2
Are you running one stick or two? It looks like it may not be fully plugged in which is causing it to show only 1 stick, also your speed would be determined from the lowest speed ram stick you have
 

Ferimer

Distinguished
Aug 19, 2011
349
14
18,795
2
when i go in task manger it says its going 1200mhz and i tired changing it in bios and it just set even lower how can i get it to 2400mhz like i bought its a320m hdv r3.0 MOBO.
Can you take a picture of the inside of your case?? you might have not placed the Ram in the correct spots, you cant just place it in any of the 4 slots ( if you have 4) you need to place it in specific spots.
 
Jan 10, 2020
23
2
15
0
im running 1x8 ddr4 2400mhz only going 1200mhz task manger says ill check if its in right slot if i can if not ill send pic
 

NightHawkRMX

Illustrious
Ahh, more reasons to hate prebuilts. A single 2400mhz stick of ram+A320 motherboard with Ryzen. That is just a recipe for poor performance.

It shouldn't matter what slot its in as it is only a single stick of ram.

I would mash delete the next time you start your PC and navigate to the button to clear all BIOS settings.
 

Ferimer

Distinguished
Aug 19, 2011
349
14
18,795
2
im running 1x8 ddr4 2400mhz only going 1200mhz task manger says ill check if its in right slot if i can if not ill send pic
Okay so that clarifies you are running only 1 but its only using half. you said you had 8 gigs but your MoBO is only drawing half its RAM "
It shouldn't matter what slot its in as it is only a single stick of ram.

I would mash delete the next time you start your PC and navigate to the button to clear all BIOS settings. "

when i saw that it only showed 4 gigs and half the speed i thought maybe he had 2 cards that's why I wondered if they were in the right slots but youre right with one stick it wouldn't matter.

Listen to NightHawk his suggestion is probably going to solve your problem i needed to determine whether you had one or two sticks
 

ASK THE COMMUNITY

TRENDING THREADS