Question So uh I think I broke my Mobo with a defective water damaged graphics card

Jan 8, 2020
14
0
10
0
No swearing please --- not allowed on these forums!

I did the “oven tactic” as a last resort to try to recover my sisters water damaged graphics card I fixed her computer 2 months ago and I don’t want this card to go to waste. Turns out after the oven tactic I assembled it again reapplies thermal paste plugged the thingys back in. Screwed both sides of the card together and wang jangled it to my pc. I took out my graphics card and put in the rx 480. Now as I go to press the power on button absolutely nothing. She’s gone. I take it out and put it mine which was just working a few minutes ago. Same result. Can someone help me out? Is my motherboard dead from a defective card? Is something unplugged? Am I utterly [CENSORED] and need a new motherboard? All these questions race through my head please help
 
Last edited by a moderator:

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

We're going to need more information. Please list your specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU: your previous GPU, not the RX480
PSU:
Chassis:
OS:

Include the age of your PSU.
 
Jan 8, 2020
14
0
10
0
PSU is a 500 or maybe 550 watt it’s a reliable brand forgot the name of it. Cpu is a and athlon x860 and I got 16 gb of ram (ddr3 the greens sticks) the GPU is a gigabyte... something I’ll take a photo for ya. Motherboard is a gigabyte with a fm2+ socket photo incoming.
 
Jan 8, 2020
14
0
10
0
/de4642de77bcfcdfcf8d1b3c3211e950 - motherboard exact model number

(Links are Glaxo having difficulties posting the forum claims it’s spam by default)

/e6d6459cb82dc636b7330a80ca5a0eb7 - gigabyte graphics card 3 fans unfortunately idk the name it’s like Gigabyte 7900 or somethin like that

But uh is there any hope for this rig? I’m sure majority of the parts function OH and the hard drive is a wd blue 1000gb hard drive
 
Jan 8, 2020
14
0
10
0
/de4642de77bcfcdfcf8d1b3c3211e950 motherboard exact model number

(Links are Gyazo having difficulties posting the forum claims it’s spam by default)

/e6d6459cb82dc636b7330a80ca5a0eb7 gigabyte graphics card 3 fans unfortunately idk the name it’s like Gigabyte 7900 or somethin like that

But uh is there any hope for this rig? I’m sure majority of the parts function OH and the hard drive is a wd blue 1000gb hard drive
 

ASK THE COMMUNITY

TRENDING THREADS