(SOLVED) BSOD atikmpag vid tdr failed

navratn123

Prominent
Jul 26, 2017
14
0
540
5
I know the same question has been asked many times but you will get my question same but problem is different .

i have a low budget laptop for my sis Dell 15 3565 MFG in 2017
The Specification is :-
AMD APU A6 7th Gen 9200
4GB RAM

Windows 10 64 bit


As the title suggested , whenever i am going to do a work like opening the MS word or playing a Video with high codec , the screen blinks many times and goes blank (Like is trying to load the frames..but fails).....
And then a BSOD saying atikmpag.sys VID_TDR_FAILED .

For solution i tried these many things......:

I completely removed the graphics driver and installed new one (Still i got the BSOD).
I installed OLD driver (oblivious i clean uninstall the driver again then installed old one)..
I installed new driver downloaded from AMD (Still BSOD)
I installed driver from Windows Update(Still BSOD)

every time i installed a driver , i first completely uninstall the previous driver completely like removed from registry etc ...


I expended sy_ to sys as i saw many in tutorial but still nowhere.....

i thought there may be something breaks on communication on PCI bridge because of BIOS so i upgraded to the latest one and still the BSOD........

Now i am really annoyed and thinking of reinstall the OS but before i want to ask if there is another solution which i slipped then please .... i'll appreciate your help.
 

navratn123

Prominent
Jul 26, 2017
14
0
540
5
Thanks for giving me this platform , as i had this problem which i guess no one paid attention as this problem was common but solution wasn't. Now i am happy that i resolved my problem my own.

Actually i did a backtracking on my pc and found what it was causing it...... and i found it quite interesting ....

The problem caused to this BSOD not because of old drivers , new drivers or pci communication bridge .....what i was found just cant accept by me but i found what happened ..... what i am gonna say is bit utterly...

It was caused by a driver for networking (I know it's strange)....

I had the Dlink Sim dongle , it's certificate was blocked by microsoft so i forced to run on my system (By removing certificate from it's executable )....
The problem if i remember correctly the problem occurred from that moment .

Now in technical word.... when the atikmpag.sys loaded to memory , it referenced to that driver (i don't know how)....
as they started to share same block memory and leads to deadlock .. it cause to fail to load the graphics frames to atimpag.sys to crash and leads to vid tdr bsod....

After removing the dlink driver and reinstall the Graphics driver now it's working as it should and using it for 1 to 2 days i am not getting any error.

I know it's bit strange and i confirmed this theory on another laptop....

HP G4 1303AU amd A4
4 gb ram
windows 10 64 bit

i saw the same bsod but it happens only sometime like (maybe when it match the condition to those on my dell , and got BSOD )
but it less frequent but yes it did happened...

I am still studying , backtracking it , hope i'll find the legit Answer to this problem . but for now this is what conclusion i reached ....

Thank you once again to provide this platform and i'll share my knowledge and work
Er. Navratn Chaudhary
Computer Engineer
INDIA
 

navratn123

Prominent
Jul 26, 2017
14
0
540
5
Thanks for giving me this platform , as i had this problem which i guess no one paid attention as this problem was common but solution wasn't. Now i am happy that i resolved my problem my own.

Actually i did a backtracking on my pc and found what it was causing it...... and i found it quite interesting ....

The problem caused to this BSOD not because of old drivers , new drivers or pci communication bridge .....what i was found just cant accept by me but i found what happened ..... what i am gonna say is bit utterly...

It was caused by a driver for networking (I know it's strange)....

I had the Dlink Sim dongle , it's certificate was blocked by microsoft so i forced to run on my system (By removing certificate from it's executable )....
The problem if i remember correctly the problem occurred from that moment .

Now in technical word.... when the atikmpag.sys loaded to memory , it referenced to that driver (i don't know how)....
as they started to share same block memory and leads to deadlock .. it cause to fail to load the graphics frames to atimpag.sys to crash and leads to vid tdr bsod....

After removing the dlink driver and reinstall the Graphics driver now it's working as it should and using it for 1 to 2 days i am not getting any error.

I know it's bit strange and i confirmed this theory on another laptop....

HP G4 1303AU amd A4
4 gb ram
windows 10 64 bit

i saw the same bsod but it happens only sometime like (maybe when it match the condition to those on my dell , and got BSOD )
but it less frequent but yes it did happened...

I am still studying , backtracking it , hope i'll find the legit Answer to this problem . but for now this is what conclusion i reached ....

Thank you once again to provide this platform and i'll share my knowledge and work
Er. Navratn Chaudhary
Computer Engineer
INDIA
 

ASK THE COMMUNITY