[solved] [closed] Sudden Stutter in The Witcher 3

Status
Not open for further replies.
Aug 7, 2020
1
0
10
0
So after one month not playing it, i decided to play Witcher 3 once again a few days ago, but i got surprised by some serious performance issue.
The game is stuttering, sometimes lightly, mostly bad as hell. No matter if I'm moving or just standing still or moving the camera, and all of that while having high FPS (avg. 90, up to 110, Drops down to 65).
Sometimes it runs fine, but that sooner or later changes randomly while playing or when I open up a in-game menu (like the inventory or the map) - then it can change from fine to stuttering but also from stuttering to fine (that seldom) - most of the time it's stuttering :).

At first I thought it's about frametimes: Forcing consistent frametimes (FPS set to e.g. 70 via RTSS or Radeon Chill) actually does help sometimes make the game run perfectly fine - until it starts stuttering again :) the ways mentioned above. Then i can watch the game lagging at what feels like 20 - 40 FPS, but officially running at 70 FPS and a perfectly flat frametime graph :).

  • classic reasons like thermal throttling or bottlenecking are definitely not the case, the cpu usage is fine below 30%, gpu usage never sees less than 90% and there are no programs running in the background despite Witcher and Afterburner
  • locking framerate via the in-game fps limiter doesn't help either
  • VSync on (but that definitely never causes trouble anyways)
  • game's stored on a HDD (like all my other games as well - even the demanding ones don't seem to suffer from that)
  • changing graphics settings, DirectX versions and other stuff doesn't help either
Today i updated my gpu drivers to Adrenaline 20.8.1 since the old one was 20.2.1 from January.
I actually got happy 'cause Witcher then was running perfectly fine for entire 15 minutes - until I opened the map :)...

And i wanna mention: all other games are fine, Witcher was running perfectly until one month ago and my pc does not have any other issues.

I really love that game and i payed money for it so pls help me guys xd

my rig:
MB: MSI B450M PRO-VDH Plus
CPU: RYZEN 5 2600X
GPU: RX Vega 56 (Sapphire Pulse)
PSU: bequiet pure power 11 CM 600W
RAM: 16 GB DDR4-3000 (Gskill aegis) with XMP
SSD: 500 GB (Crucial P1)
HDD: 1 TB (Toshiba P300)
 
Last edited:
Status
Not open for further replies.

ASK THE COMMUNITY