[SOLVED] [SOLVED, for now] Can't update BIOS (X570 Gigabyte Aorus Elite)

Countess_C

Proper
Aug 24, 2019
104
25
120
4
It was supposed to be quick and easy to use Q-Flash Plus to update BIOS... I downloaded the latest BIOS, unzipped and put the files on a USB-stick and renamed the BIOS file to GIGABYTE.BIN. Turned the computer off and put the USB-stick in the right place on the back and clicked the QFLASH_PLUS button on the motherboard. Nothing happened. Tried again with the computer in energy saving mode, and again nothing happened.

I googled and read that the computer should be in "S5 Shutdown State". Ehhh, ok? I googled but found no info on how to put the computer in that state. I read on a forum that one needs to turn "fast start up" off in the energy settings for the computer to go into read "S5 Shutdown State". I tried that but again nothing happened.

Then I tried the Gigabyte utility "@bios". It seemed easy to use in the instructions. But I couldn't even install it because it crashed on startup, missing DLL's and whathaveyou. 😕

Am I doing something wrong? Do I have to remove all the hardware from the motherboard to be able to use Q-Flash Plus?

Edit: OK, I found Q-Flash in the BIOS and managed to use that for the update. So I'm good now. (At the moment. I'm sure I will have more problems soon =P )
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS