Question [SOLVED] HDD states its unallocated, but there's still data in it (Foreign Dynamic disk)

BathinApe

Honorable
Mar 14, 2014
24
0
10,520
1
Hello everyone, once again. Unfortunately this time i didn't come to help, but to be helped. I did a very very stupid thing.

On my laptop, I have 256GB SSD (OS here) and 1TB SSD (only important data here)
I installed my Windows like 4 years ago and didn't even notice that i used only 750GB of the 1TB HDD i had. So I decided to extend that to use the unallocated space, right? Nothing special. BUT when i tried to extend it (with EASEUS Partition Master) it asked me to convert my whole HDD to "Dynamic" partitions, so it can act as a whole drive (keep in mind this is NOT merging). And that was my biggest mistake. Because:
Dynamic disks cannot be converted back to basic ones.
Dynamic disks cannot be backed up.
So i thought the only thing left to do is simply copy ALL the 750GB data to another HDD, format my hard drive and copy back the data to the original hard disk.
Silly me, i thought data transfer over ethernet cables would be a slow thing, so I decided to connect it to my PC over SATA Express cable (because of the speeds) and I did. Ofcourse harddrives are not hot swappable, so i restarted the PC. Then I had access to it. I was able to copy, paste, delete and etc... no problem so far. But then I decided to defragment it and check for bad sectors (because the copying was like 1MB/s). I analyzed the disk, ran the defragmentation process (somehow finished very fast) and when i tried to check for bad sectors the power in my house went down.
Now I can't see it in the explorer. I can see it however in Windows's "Disk Management" tool.
Heres what i can see in Disk Management:

So basically Disk 0 is the 256GB SSD and Disk 1 is the 1TB HDD.

Here is what i see in EASEUS Partition Master (it clearly seems like the drive its empty, BUT check the next picture)


And here is what i see in MiniTool Power Data Recovery software (I can clearly see the HDD is NOT empty as EASEUS showed)


Question is... what am I supposed to do now? I want to save the data, but in the same time i am afraid to use a "recovery" program, because i am not sure what the outcome might be.
 
Apr 13, 2019
9
0
10
0
if you didnt format that 1tb disk, and it lost the assigned letter, you can try to REASSIGN and REACTIVE it, with diskpart

but, if you think you formated the disk, and want to recover everything, you will can, but try to not write nothing more on it until you get all your data back
 

BathinApe

Honorable
Mar 14, 2014
24
0
10,520
1
Guys, thanks for your answers!
I found the missing piece of my puzzle. The reason why I couldn't see the files on my laptop was because I made my HDD dynamic from my laptop (Windows 10 Pro) and when I decided to transfer my files faster by connecting it to my PC with SATA Express cable direclty (my PC is Windows 10 Home) it just messed up the drive when i tried to read it.
More in depth explanation: "When you move a dynamic disk from one computer to another one which does not support dynamic disk, such as all Windows home editions, and then the dynamic disk created on the previous computer will be flagged as a foreign disk in Disk Manager."
link for the quote: What is Foreign Dynamic Disk and How to Fix it

So no need to assign a new letter with diskpart now. I just went to the "Disk Management" tool and clicked "Import Foreign Disks" on the 1TB HDD. I am NOW transferring my files over Ethernet cables.
Thank you once more.

Last Question: How am i supposed to give this thread a [SOLVED] mark now?
 
Last edited:

USAFRet

Titan
Moderator
Mar 16, 2013
111,894
1,609
154,440
18,454
Yes, i did. That's not how it works?
Right.
Being awarded Best Answer builds reputation.
While it is functionally possible (for now) for a person to select his own answer as The Solution, it is strongly discouraged. Even if that IS the "Best Answer"

A person could post 100 questions, and grant himself the BA in each. Gaining many points in the reputation system.
 

ASK THE COMMUNITY

TRENDING THREADS