Question (Solved) My Computer restarts when GPU fan speed isn't at 100%

Feb 18, 2019
1
0
10
0
I recently reinstalled Windows 10 into my PC:
-Processor: Intel Core i5-7400 CPU @ 3.00GHz
-Video Card: NVIDIA GeForce GTX 1050 Ti
-Motherboard: MSI H270M BAZOOKA
-RAM: 2x8GB DDR4 2400MHz Ballistix Sport LT
-PSU: Thermaltake TR2 700W

Everything went fine until I installed the NVIDIA Drivers for the GPU (418.91 specifically)
The computer restarted without any message and booted up into the desktop again, then after 30 seconds it just restarted the same way.
I decided to boot into safe mode and use DDU to unistall the drivers, then I installed older Drivers (378.92), it also restarted.
I reinstalled the up to date drivers again, and discorvered that the restart would only happen when the GPU was idle.
As an example: if I turn on the computer and play a youtube video the computer won't restart until I close the video tab.
Then I installed MSI Afterburner to check what was going on and everything looked fine (No overheating or weird spikes), but by some reason I decided to turn the GPU fan speed to 100% (everything else on default) and the system stabilized, I was even able to run the FurMark GPU stress test without any trouble, but as soon as I set the fan speed to "auto" the system restarted as before.

I've been many hours trying to figure out what's wrong with the system and can't find anything.
Thanks in advance to anyone who decides to help me.

EDIT: Something was shorting my motherboard. I dissasembled the entire PC and cleaned it, then carefully reassembled it, everything is working fine now.
 
Last edited:

ASK THE COMMUNITY