Question (SOLVED) Netgear A6150 Adapter can't see 5GHz anymore

Aug 21, 2019
6
0
10
0
So I've looked for a few hours without finding anything that's helped me with this... here goes. I bought the Netgear AC1200 WiFi USB Adapter (Model number A6150) today, because I wanted to connect to my home's 5GHz wifi network. I've been using the 2.4GHz, which gets interrupted whenever someone turns on the microwave, and apparently 5GHz doesn't get interrupted. So I had to buy this for the dual-band capability. It specifically said "Works with any WiFi Router" on the box, so I figured it would be safest to get this. Anyway, I get it, I install the drivers for it to work, and immediately, it sees the 5GHz network and works perfectly, data speeds are perfect, everything is great. But about 1 minute in, it just drops everything completely. It can't see my 5GHz, 2.4GHz, or any of the neighbours' networks. I used the network reset button on windows, which said it would reinstall the adapter. After resetting the computer, the adapter worked again, but it can't see the 5GHz signal. Strangely, I think it sees my neighbours' 5GHz networks, though, unless they're named really weirdly. Here's the wifi settings, I'm looking for D-Link 2888A 5GHz. View: https://imgur.com/vGUaxmT



Here's the netsh wlan show drivers:
View: https://imgur.com/v91m73N


Here's the 5GHz network settings:
View: https://imgur.com/qkhCB0G


Here are all the network drivers, including hidden ones:
View: https://imgur.com/f3lWCzQ


Here are the advanced settings for the driver:
View: https://imgur.com/QT986w5


I've fiddled with some of these settings but nothing has worked. I tried setting the driver wireless mode from auto to just about every other option it has, but none of them work for the 5GHz, and most of them actually just don't see any networks at all. I've tried uninstalling and reinstalling the drivers. I tried uninstalling previous drivers from my old adapter. I just don't know what else to do.

So it's not a distance thing, I'm very close to the router and it could see the 5GHz network beforehand, it also might not even be a 5GHz thing, as I can see neighbouring 5GHz channels. It's not the actual 5GHz network, I've reset the router and I can connect to it just fine with my phone... I have no idea what's causing this. Please help!
 

ASK THE COMMUNITY

TRENDING THREADS