[SOLVED] New Build wont post or display. Tried Everything.


Apr 3, 2015
Hi guys,
So i just built my new pc and the parts i have are:
intel i7 4790k processor
corsair vengence pro 2x4GB ram
asus z97 pro wifi ac motherboard
corsair cx750m psu
seagate 1tb hdd
samsung evo 250gb ssd
corsair 780t case
corsair h105 liquid cooler
5 120mm case fans

When i start the pc, everything inside seems to be working graphic card lights up, mobo lights up, case fans and liquid cooler work. I have also touched the processor and it heats up indicating it is working. Tried switching rams and only putting 1 at different slots. Removed everything except ram and processor to see if that worked (also only put in 1 ram and switched it). Nothing worked. Im sure all the wiring is correct and my mobo has a built in sound card and also that the standoffs are placed correctly (780t case already comes with standoffs so u only have to put in screws). The mobo counter gives the AE indicator which meant legacy boot event. I thought maybe my pc is not suppose to give a beep sound so i tried to do enter bios and nothing came on display but instead the mobo counter changed to A0 which meant IDE initialization has started. Still nothing comes on display, i plug my pc to my tv with a hdmi (plugged in mobo hdmi, not the gpu hdmi) for display btw. To be honest, i am sorta depressed since this is my first build and i went with high quality parts and still it is not working. After hours and hours of trying to make it work, i gave up and cursed my luck. I was wondering if anybody would be so kind as to help me with my problem.

EDIT: Solved the problem, just needed to plug hdmi into gpu instead of mobo. Ty for anyone who helped.
Double check that no extra motherboard standoffs are used/installed. There should be no more than 9 standoffs required.

Remove CPU and check it and its socket for damaged and missing pins/pads.

Re-seat CPU and its cooler carefully and evenly. If there is too much pressure on one side of the CPU it might lift slightly and lose contact with some pins.

Clear CMOS.

BIOS may have to be updated to support the i7-4790K CPU. To do this requires the use of an earlier model of CPU (temporarily).

Check that the DIMM's and video card are seated properly.


Similar threads