[SOLVED] [SOLVED] New RTX 3080 Underperforming

Aug 19, 2021
EVGA RTX 3080 XC3 Ultra
Ryzen 7 3700x
Aorus Elite X570
16GB RAM 3600Mhz CL 16
1TB 4.0 M.2 SSD
750W Corsair RM750X 80+ Gold PSU

I'm using native 1920x1080 resolution, connected to my 240Hz monitor using a Display Port cable.

My RTX 3080 card is running at unusually low GPU and Memory clock speeds. It's never been overclocked and I've been experiencing these issues since first use. When I initially open EVGA Precision X1, I see a memory clock speed of 9502MHz and GPU clock speeds 1755Hz. After about a second, it gradually falls off and then will stay at its lowest memory clock of 405MHz and GPU clock of 210MHz. When I load a game, it behaves similarly where initially the clock speeds increase then falls off again seconds later.

My FPS in games is also far lower than it should be as I have the same card in another build running at a constant 200-300fps more (paired with Ryzen 7 5800X). My previous RTX 2070 Super performed better than my current RTX 3080. Because of this, I considered CPU bottleneck but my CPU load never exceeds the GPU load during gaming.

Thing I have tried:
  • Reset my PC (kept my files)
  • Reinstalled the game
  • Reset NVIDIA Control Panel settings and adjusted image settings to performance
  • Reinstalled NVIDIA Game Ready drivers and GPU drivers from EVGA
  • Windows capture and Game mode turned off
  • Power plan is set to High Performance
  • Flashed and updated my BIOS (Gigabyte; previously running version F4 updated to F30)
  • Enabled XMP in BIOS
  • Swapped out my custom cables for stock cables which came with my PSU, also tried a different PSU that is 850W - no difference
  • Tried different extension leads and outlet
The graphics card is plugged into the best possible slot on my motherboard PCIE 4x16, RAM is also configured correctly according to my motherboard manual.

I've since uninstalled drivers using DDU in safe mode. I've also tried swapping out the RAM and using a different PCIE slot.

Now considering getting a new motherboard.

Any other suggestions would be very appreciated :)
Aug 19, 2021
After uninstalling drivers with DDU and re-installing them as well as my AMD chipset drivers then setting prefer max performance in NVIDIA control panel, it's finally fixed!
Reactions: RobK92