Question [SOLVED] No Linux distro would boot with GTX 1070!

jrglol

Commendable
Jun 27, 2017
53
0
1,540
1
I have a ZOTAC GTX 1070 AMP! Extreme, and nothing would boot besides Windows. I always end up with end kernel panic error. My iGPU boots without a problem. Can anyone help me, I had this issue for 2 months now.

My full system spec :
AMD R3 2200G (@3.8Ghz)
Asus B450M-K
ZOTAC GTX 1070 AMP! Extreme
Kingston 8GB 2666Mhz (@3000Mhz)
128GB Kingston SSD (main linux drive)
1x 500GB Hard drive (personal data)
1x 1TB Hard drive (win10)
650w Thermaltake PSU (80+ Bronze)

SOLUTION :
https://forums.tomshardware.com/threads/no-linux-distro-would-boot-with-gtx-1070.3463648/post-21346843
 
Last edited:

mitch074

Distinguished
You can also boot in fail safe mode and load the proprietary Nvidia drivers - the open source driver for Nvidia card gets almost no support from the manufacturer, and some cards just won't boot because no developer could actually test that exact model.
 

jrglol

Commendable
Jun 27, 2017
53
0
1,540
1
You said you were able to boot with the iGPU without a problem.
If you cannot boot with the live USB maybe you have other issues.
Could you provide the kernel panic error you're getting?
Yes, I can boot with the iGPU. Every distro I try has different kernel panic error. I cant remember them.
 

jrglol

Commendable
Jun 27, 2017
53
0
1,540
1
You can also boot in fail safe mode and load the proprietary Nvidia drivers - the open source driver for Nvidia card gets almost no support from the manufacturer, and some cards just won't boot because no developer could actually test that exact model.
Already tried that. No dice.
 

jrglol

Commendable
Jun 27, 2017
53
0
1,540
1
Meaning that the card didn't boot in failsafe? Or that booting in failsafe mode then installing the Nvidia proprietary drivers didn't work? If it's the latter, I suspect a faulty card (or a compatibility problem with your motherboard).
Nevermind, I found the solution. The IOMMU option in the bios was set to auto by default. I just highlighted it to off, and I can boot into any distro now. I have no idea what IOMMU does or whats its for, but it works now.

P.S. sorry for the late reply. I didnt log in since then.
 

mitch074

Distinguished
Nevermind, I found the solution. The IOMMU option in the bios was set to auto by default. I just highlighted it to off, and I can boot into any distro now. I have no idea what IOMMU does or whats its for, but it works now.

P.S. sorry for the late reply. I didnt log in since then.
The IOMMU is a component that does memory address translation / isolation in a system (typically on AMD system, disabling this feature makes it impossible for you to run a virtual machine with any performance). However, they can cause error on a system when they are not properly addressed : typically, motherboard makers will only make sure that their own management logic works with Windows, and Linux will try to follow the spec - causing it to crash.
There are kernel boot parameters that would allow you to simply isolate the hardware causing the problem - here I'm pretty sure the one causing trouble is your Geforce. You could try reporting the bug to Nvidia, as it seems their driver is doing something funky with your BIOS.
 
Reactions: jrglol

ASK THE COMMUNITY

TRENDING THREADS