[SOLVED]Only 256MB ram support on Gigabyte VIA embedded mb?




I've built a media centre computer (more just a music centre really) behind my stereo cabinet, It consists of;

GA-PCV2 mITX motherboard (Via embedded 1ghz c7 processor, 1 dimm slot)
100gb pata hard drive
300w power supply
**currently 256mb ram**
XP Sp3 installed

Everything is working fine, I have it hooked up to a 15" touchscreen monitor and am in testing stages for various
media centre apps.

My problem is it seems to only work with 256MB ram.. I have several 512mb chips also a few 1gb chips (ddr400) but it isn't working with them and produces no video (on occassion however it did work every 2nd boot with a 512mb chip when i was setting it all up but now it doesn't work at all..)

I've searched through Gigabytes motherboards but there is no page for this one.. possibly an oem board.

I have just tried updating the bios from the IDOT website, to V2CSIDSI.F5e , While the bios update went smoothly I'm still getting a blank screen with anything more than 256mb ram. (the 256mb is rated at the same speed etc as the larger chips ddr400)

any ideas? thanks

P.S. i could not set the sub-category as gigabyte as it's not letting me scroll down in the menu


Have got it working now.. with 1gb ddr400.
It might've been a problem with Serial Presence detect as when i entered the values in manually (press Ctrl+F1 in bios to access advanced ram settings), it now works fine (every time) with 1gb ddr400.