Question [SOLVED] Overclock not sticking ASROCK B450 A/C

Faint

Prominent
Jan 14, 2020
11
0
510
0
Hello people, after accidentally opening up task manager and looking at my CPU and ram my oc which I previously had is not there anymore?
Ryzen 7 1700 overclocked to 3.9 ghz 1.4v
DDR4 Corsair Vengeance RGB to 3200MHZ
Right now it says my base speed is 3.00 ghz and my ram speed is 2133, I tried changing this in the bios (I enabled XMP and everything, messed around with the voltages and nothing sticked)
Current BIOS version is P1.40 (maybe it's an update issue?)
I reset my bios to factory and changed my settings there and booted up windows still no change.
Motherboard: ASROCK b450 a/c
Some Images: https://ibb.co/BLfd7jQ https://ibb.co/ZBPwBbv https://ibb.co/NLyGZXq https://ibb.co/xCMyVMM
 
Last edited:

Faint

Prominent
Jan 14, 2020
11
0
510
0
if you keep XMP disabled and just overclock CPU, what happens?
So when I disable XMP my CPU actually does overclock! But my ram doesn't obviously. So could this be an issue with my ram? Maybe one of my ram sticks wasn't put in properly? I remember one of them wouldn't clip all the way after hours of trying so I just gave up.
 

Faint

Prominent
Jan 14, 2020
11
0
510
0
if you keep XMP disabled and just overclock CPU, what happens?
So I checked my ram slots and turns out one of them was stopping my oc from working, I reseated them and viola it worked! Thank you for the tip I would have never known it was my ram.
 

ASK THE COMMUNITY

TRENDING THREADS