Question [solved] Unused printer - produce only blank sheets (Epson XP-432)

Grobe

Distinguished
Jan 22, 2009
684
17
19,165
98
I have just unpacked the printer, mounted it, inserted the cartridges and then connected it to the WiFi.

The problem is that every page I attempt to print, resulting in blank pages with no traces of ink whatsoever. It doesn't matter if I trying to print a test page via the front panel on the printer itself or if I try to print from another device.

The currently inserted cartridges is the ones that was shipped in same box as the printer itsef.
The printer was phurcased just over a year ago, has not being unpacket since today. I wonder if it may simply be the included cartridges that may have being dry out, even if vacuum packed? The storage environoment at winter season temperature regulated to around 10 deg. celcius and at the summer it had being raised to almost thirty degrees.

As mentioned - the printer have not being outside the box until today.

This is what I have tried, with no luck (Still produces pages without ink)
  • Nozzle Check, using the front panel on the printer itself
  • Head Cleaning, using the front panel on the printer itself
  • Print Head Alignment, using the front panel on the printer itself
  • Cutting the power in about thirty seconds bu pulling the power coord.
I also have an extra set of cartridges - but I don't want to waste a set of cartridge if the cause of the failure turns out not being the cartridges iself.
I removed all visible bits of tape (those for shipping) during unpacking and installation.

Anyone have experienced similar problems ?
 
Last edited:

Grobe

Distinguished
Jan 22, 2009
684
17
19,165
98
Problem solved.

It turned out I have omitted removing the small yellow stickers on the ink cartridges. Once the stickers removed, I was able to use the printer normally.

Only downside I had to run "Ink Cartridge Replacement" procedure, that wasted much of the remaining ink.
 

ASK THE COMMUNITY

TRENDING THREADS