[SOLVED] [SOLVED] Won't get passed motherboard logo and can't reinstall windows from flashdrive

Pappa91

Prominent
Feb 5, 2020
7
1
525
1
[UPDATE] Manage to solve the issue was in fact a faulty SSD (the Lite-On one to be exact) Thanks SkyNetRising for the input!
Hi!
Yesterday my PC had a sudden blue screen but before i could check the error message my PC proceeded to reboot. But the issue was that now my pc won't boot passed the manufacturer logo and just keeps loading.
I tried to reinstall windows since i thought that might be the issue but after selecting windows 10 startup installation i get stuck on the same screen again.
I tried booting up in safe mode just to yield the very same result.

I do have to mention that i've had Blue screens before refering to something about memory, sadly can't remember exact stop code nor message...

I've read that it could be caused by bad ram but only have 1x8gb ram installed so can't test if the ram is the culprit, but i asked a friend to lend me a ram and he might come by today.

But I wanted to hopefully get some other ideas what could be the problem if the ram isn't the problem.

Thanks in advance!

  • UPDATE 1: System Specs:
    MB: Asus ROG Strix z390-F
  • RAM: 8GB SK Hynix(only label i found on it took it from an old acer PC i had)
  • GPU: GTX Geforce 1060 3GB
  • CPU: i9 9900K
  • SSD: Kingston A2000 250GB M.2 (OS is installed on this)
  • SSD: Lite-on 256GB m.2
  • SSD: FireCuda 120 2TB
    OS: Windows 10 Pro 64-bit
PS: Will update when i have tested the ram my friend is lending me and If you need to know more i'll try my best to provide the info

Rich (BB code):
	
 
Last edited:

ASK THE COMMUNITY